MPC Software specific discussion - bug reports, feature suggestions and general MPC Software related topics. If you have hardware-soecific questions, please post in the relevant hardware forum.
User avatar
By quietizkept Fri Jun 01, 2018 11:07 pm
Ok, all you have to do is browse to:


There you'll see a file called MPC.SETTINGS

Open it with Notepad, and search for "scan"

You'll see an entry that says:

<VALUE name="PluginScannerTimeout" val="40000"/>

Change 40000 to 99999 then save.

Restart your PC, then do a "rescan all."

Not only did the Waveshell scan successfully, but all the other ones that had crashed scanned successfully too for me. I guess timing out was the issue all along. Of course 32 bit plugins won't work.

If you want a clean install, Revo Uninstaller is free and will leave no traces of the MPC software so you can start fresh.

I don't have a Mac currently, so I can't test it on there. I have no idea if or where such a file exists on Mac.

:nod: :smoker:
Last edited by quietizkept on Sat Jun 02, 2018 6:00 am, edited 1 time in total.
User avatar
By optik415 Thu Aug 09, 2018 10:04 pm
I upgraded to Waves 10 and my plug-ins wont show up! This is the first time I did the hack, I thought it would work but only 2 virtual instruments are working. I had my waves V.9 working perfectly! Can anyone help or confirm if Waves 10 is working or not? I really dont want to do the 1.6 hack cause its kinda a headache and has no guarantees
User avatar
By optik415 Fri Aug 10, 2018 2:48 am
Certified Beatz wrote:On the road but i believe it's called vstshell it works well.. it creates all .dll for waves plugins.

Not sure if thats around still! Did a Google search and got nothing but old results from 2005.
User avatar
By optik415 Fri Aug 10, 2018 2:57 am
It's actually shell2vst! I'm also gonna try scanning the plugs using MPC as a plug-in to see if that works. This issue has always been a headache and takes up alot of time. Will try as soon as I get home from work, wish me luck
User avatar
By optik415 Fri Aug 10, 2018 4:31 pm
Still not working! Tried multiple method's. My last resort is to try shell2vst which I feel I shouldn't have to do but that's all I have left. Might give akai a call. So annoying
User avatar
By optik415 Fri Aug 10, 2018 5:22 pm
Just to point out! I'm using Win7, could that be part of the problem? Anyone here using Win7?
User avatar
By optik415 Mon Aug 13, 2018 7:58 pm
Certified Beatz wrote:No it works i used it in windows 7 before.. you have to create a waves folder then drag and drop each file in. Then on the command screen you will see the .dll's being created

So I did the shell2vst method since I had no choice and it worked fine but a couple plug-ins didnt make the scan such as: Metafilter and all the instruments plus i still had the "99999" value on the notepad so im not sure why those didnt work. No biggie as i can open the instruments in Komplete Kontrol. Thx for the help! Eventually im gonna have to upgrade to Win10. Another plus is the Waves VST's dont take up as much CPU as the shell.