Support and discussion about Akai's next generation of standalone MPCs running the MPC Software 2.0
By Carmichael84 Thu Dec 07, 2017 4:36 am
Looking for a little help here on sorting out this issue.

I'm getting a midi feedback loop on my MPC X using a Little Phatty + 2 Slim Phattys in poly chain mode. A slightly unique issue maybe, but I've also run into similar feedback issues with my Rev2.

Setup is:
Midi OUT A > Little Phatty Midi IN > Slim 01 Midi IN > slim 02 Midi IN >>> Slim 02 Midi OUT to MPC X.

I've tried with local control on and off. No difference. Even just the Little Phatty on it's own as in and out is feeding back.

In other DAW's I know usually a turning off soft thru or similar helps, but I have no idea on the MPC X?

Any help?

Thanks Yall/
The complete guide to learning the MPC X & MPC Live
By Carmichael84 Thu Dec 07, 2017 4:13 pm
Hey thanks for the reply!

Great suggestion, I'll have to look into blocking a channel on the MPC X.

Funny enough I just upgraded from a 2kXL I've used for probably a decade and never had feedback issues...
By marctronixx Thu Dec 07, 2017 9:14 pm
Nothing funny. Two different machines. The live/x is basically a laptop with a DAW built in.

There is a learning curve with this machine, even if you ar a master at the 2Kxl (i cut my teeth on the 3000 then ended up with a 2KXL studio plus until i got the live/x)
By Carmichael84 Fri Dec 15, 2017 3:29 am
Yeah, don't get me wrong, loving the X. It's a total beast. Everything I wished my 2kxl would do it's doing. The CV's are the main reason I picked it up to integrate with my Modular. So far really fun.