Post your questions, opinions and reviews of the MPC1000. This forum is for discussion of the OFFICIAL Akai OS (2.1). If you wish to discuss the JJ OS, please use the dedicated JJ OS forum
By justiinclark Sat Feb 04, 2017 11:19 pm
Hi, I am new. Thanks for humoring me. I have scoured the internet and forums and found no solution.

I bought this used 1000--the blue one, which I'm beginning to think was a mistake. Anyway, before learning anything about the akai OS I wanted to install jjos (the basic one). so
-i plugged into my computer with the mpc on.
-pushing load mode and f4 to put it into usb mode didn't seem to work, but whatever, i just unplugged the sd card and plugged it straight into the computer and dragged the jjos file on to it as the instructions said.
-THEN, i tried to turn the mpc on and it looked the same as before with no install prompt so i figured maybe i needed to erase the old os,
-SOOOOO i tried to power on while holding the erase button but never got the reboot confirmation, the screen just stayed blank. now the screen is still blank, I've turned it off and on and unplugged ram etc etc and the screen just stays blank until i power off and it does the quick blip line and turns off. the A button lights up though and the blip on shutdown means the power is working fine..

any idea what happened to the screen? i already tried the contrast commands. is this thing broken?

thank you.
User avatar
By Psychedelic Schizophrenic Wed Feb 08, 2017 12:46 pm
It sounds to me like it could be a loose ribbon cable inside the machine that is causing the issue. The best bet would be to open the machine up and reseat each of the ribbon cables inside to see if that fixes your issue. I once had a similar issue with my 1000 and it turned out to be the ribbon cable that was located underneath the hard drive that was causing the screen to sometimes go blank. Touch wood everything has been ok with my 1000 since I reseated the ribbon cable.