Technical questions for the MPC2000xl and the MPC2000
User avatar
By connormc0 Fri Nov 08, 2019 12:16 am
Was just curious if anyone has had any luck with either of these cards before? Just recently installed a cheap IDE to CF adapter & no ATAPI option found under SHIFT+3 while using the off brand 1gb card...
Image




I haven't received the second card yet but I read on gearslutz "Buy older industrial cards off eBay, they have the true IDE/UDMA tech on the cards." so I am hoping this will do the trick!
Image

This is the IDE to CF chip I'm trying to use
https://www.ebay.ca/itm/002A-Compact-CF-To-3-5-40Pin-IDE-Bootable-Adapters-Converter-Kit-General-Purpose/332993830048?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2060353.m2749.l2649
Image

So far I have tried all jumper settings on OS 1.14 & OS 1.20 with the 1gb card, I have also tried formatted as FAT & FAT32 both the full 1gb & then a 512mb partition with the rest unallocated space & no luck any which way...


the adapter i'm trying to use can plug directly into the motherboard & I also have a 40 pin male to female ribbon cable that can complete the connection as well, I cant put the bottom plate back on when the adapter is plugged directly into the motherboard tho...

for power I am using the 4 pin molex that was connected to my floppy drive,

the adapter has 3 indicator lights, "detect" & "power" are always lit up when the mpc is powered on,
while in slave mode the middle indicator labeled "Active" Stays lit,

I noticed while in master the middle LED labeled "Active" will light up for a split second when powered on using OS 1.20 vs remaining completely dead using OS 1.14 making me think the mpc is at least seeing the adapter in 1.20 but not liking the card i'm using so no ATAPI option under SHIFT+3

Have been through many threads on the topic & I do think the CF card is the determining factor when it comes to ATAPI popping up under SHIFT+F3 but not 100% sure

Will update once my 2nd card arrives in the meantime has anyone had any luck with either of those CF cards? Was also wondering if anyone has got one of the cheaper adapters without the housing to work?
User avatar
By Lampdog Fri Nov 08, 2019 3:27 am
Good then it's "keyed".

You'll see ATAPI when the mpc recognizes the adapter. The CF being in the slot has nothing to do with that part.
CF comes into play when you choose OS and size of card. I've always used a Lexar 512mb and have never had problems with it. Used it constantly between 2kxl and Triton Extreme for years. I have a full on ATAPI hot swap MCD reader so I can't help much with the brand or troubleshooting your adapter. You said you've tried several jumper settings, checked pwr and data ribbon already.
User avatar
By connormc0 Fri Nov 08, 2019 2:21 pm
Had read on another thread:

"Personally, I've never seen a card reader drive that required a certain brand of CF card."

"That may be true, but in my recent experience I have been sent a card (non-branded) that wasn't recognised at all. I got a full refund so it was cool once I bought a new card.

With no card in the MPC I also recieve the message "No floppy device"... "ATAPI" isn't even an option until I power up with a working card in the drive."



I think with some of these cheaper non hotswappable adapters the CF card is the determining factor as to whether or not ATAPI is gonna pop up under SHIFT+3 or not but still not 100% sure... I do get signs of life while powering on thru OS 1.20 vs OS 1.14 making me think it's at least checking for a compatible CF card before loading into the home screen
User avatar
By Lampdog Thu Nov 14, 2019 2:59 pm
Mine is 17yr atapi hot swap mcd and I’ve never used a non-hotswap so I don’t
know how they act and what brands they are compatible with.
User avatar
By connormc0 Tue Nov 26, 2019 12:56 am
Just figured I'd leave an update now that I got everything going! The 1GB off brand & 4GB transcend cards did not work any which way, ended up grabbing another IDE to CF & a few more CF cards, these 64mb Cisco cards
work flawlessly in both my card readers!

****CONFIRMED WORKING****

$3 card reader on ebay (not hotswappable)
Image

$20 Startech IDE2CF (not hotswappable)
Image

Cisco 64mb CF #1 $2.65
Image

Cisco 64mb CF #2 $2.65
Image

All in all i spent like $60 trying 2 figure it out but a floppy to CF upgrade can be made for as little as $10 Canadian if the right card reader/cf combo is made!

The $3 card reader takes a 40 pin male to 40 pin female ribbon cable

The Startech card reader takes a 40 pin female to female ribbon cable, if one of the holes are blocked on the 40 pin can make a hole for the 40th pin using a razor blade


hope this helps someone!
User avatar
By JUKE 179r Tue Nov 26, 2019 7:45 am
This is good news. Cheers connormmc0!
I keep trying to sell (mind you, no profit to myself!) the SCSI2SD card reader due to the ease of install and immediate use on the XL but this is definitely a cheaper and working alternative.