Technical questions for the MPC2000xl and the MPC2000
By Shawnsick Wed Mar 25, 2020 8:34 pm
Hello,

I am new here and this is my first post, so please forgive me if I'm not posting in the right place !

After reading several topics about using an SCSI2SD V5.1 with the MPC2000 Classic, I thought I'd bite the bullet and give it a try as floppy disks just aren't working out for me, but unfortunately I can't get it to work as expected. Whenever I go to format the SCSI drive on the MPC I just get an "SCSI not ready" message. I have tried configuring different SCSI addresses in SCSI2SD-util but I'm still encountering the same problem.

I will try to provide as much information as I can and as clearly as possible, sorry if there is too much:

I am using the SUB DB25 port on the V5.1 directly onto the MPC (Waiting on the the SCSI2-SCSI1 IDC50 to DB25 adapter to go internal once it's working)
I have tried 3 different SD Cards Sandisk 32gb, Sandisk 16gb and an old unknown brand 2gb
I am using a USB cable to power the SCSI2SD (Powering up the board before powering up the MPC)
I am using OSX and formatting using the default FAT in macs diskutility app (have tried using SDCardFormatterV5)

Here are the settings I have uploaded to the board:

General Settings:
Ticked Enable SCSI Terminator (V5.1 only) I have tried unticking this and I just get a "waiting" message when I scroll through the drives in the Disk menu on the MPC.
SCSI Host Speed: Normal
Starup Delay: 0
SCSI Selection Delay: 255
Everything else is unticked

Device 1:
Ticked Enable SCSI Target
SCSI ID 0 (I have tried all except 6)
Device Type: Hard Drive
Quirks mode: None
SD card start sector: 0
Sector size: 512
Device size: Have tried anything from 400MB to 2GB
Vendor: codesrc
Product ID: SCSI2SD
Revision: 4.2
Serial number: 1234567812345678

I have read of 2 people on this forum using SCSI2SD on the MPC2000 Classic, Plasticlegs and hok-2:

viewtopic.php?f=1&t=182060&start=30#p1760014

viewtopic.php?f=1&t=171256&start=45#p1756321

Any advice, ideas would be appreciated, and I'm pretty certain we could help out others !
User avatar
By richie Thu Mar 26, 2020 12:07 pm
First of all, it's great you actually provided detailed information on what you have tested and where you're at with this.

Have you by chance tried to put an unformatted sd card into the SCSI2SD without bothering to do anything with the setup utility? Provided that the 2000 is reading the SCSI2SD correctly, it should still recognize it and let you format it as a single drive. Now I do realize that this may not be what you're trying to accomplish, it's just a matter of testing to see if that works.

Speaking of the 2000 reading it correctly - You said that you power it on before the 2000; which is the correct thing to do. My question to do you is, do you see the 2000 recognize the SCSI2SD while booting up? You know, it'll do a scan of the SCSI bus before going to the main screen.

Connecting the SCSI2SD to the DB25 on the back is totally normal, what I'm wondering about is the lack of termination causing this. Do you happen to have any other external SCSI devices that you can daisy chain the SCSI2SD to? It can be of great help in troubleshooting what could be going on with the 2000's SCSI bus.

Now while I do realize that the 5.1 does in fact have resistor packs for handling termination, I some how believe that your issues may be tied to it.
By Shawnsick Thu Mar 26, 2020 1:46 pm
Hello richie, thank you for your reply.

I have tried with 5 different cards at this point, without formatting them on my PC, but whenever I try to format them on the MPC2000, I just get the "SCSI not ready" message.

The MPC doesn't seem to be scanning the SCSI bus while booting up, I'm only getting the "MPC2000 BOOT ROM V1.00" followed by the "MPC2000 V1.72" messages.

Unfortunately this is the only SCSI device I own and have no access to any others.

I am starting the the wonder the same about termination problems...
User avatar
By richie Thu Mar 26, 2020 4:32 pm
Hey Shawn,

I don't think it has to do with the cards at all. I mean, if you were to connect the SCSI2SD to your computer, it recognizes it fine right? Since you verified that the 2000 doesn't see it at start up, then that is a problem and also can partially explain why you're getting that SCSI waiting message, it simply cannot handshake with the SCSI bus to init.

Random thought, turn on the 2000 without a card installed and see if it even recognizes it that way. Also, the SCS2SD should be able to function on bus power alone, not requiring that USB connector to supply the 3.3v. Or at least that is how it is on the 5.0, I'm not entirely sure if it's the same thing with 5.1

The reason why I asked about an alternate SCSI device, be it a zip drive, cdrom, just anything external that is SCSI can be used as a termination point as well. Now while the 5.1 does have that resistor pack to handle termination, I have seen instances (at least with the 5.0) that removing that resistor pack and providing alternate termination (again such as another scsi device, or even a SCSI active termination dongle) has helped. This may not be necessary with the 5.1 due to the ability to set termination on and off within the software configuration but it is worth looking into.

But first things first - Again if you can find any external scsi device locally for cheap, it would be in your best interest to do so.
By Shawnsick Thu Mar 26, 2020 5:08 pm
Thank you for your fast and detailed reply ,Richie !

If I try to access the SCSI drive in the disk menu on the MPC without the USB cable feeding the module, I just get a "wait" message and no longer the "SCSI not ready" message, and there is clearly no power getting to the SCSI2SD module, so....

... After a bit of head scratching I am suspecting the SCSI's ICP fuse (FS1 on the mainboard) to be the issue here. I am not reading anything from pin 25 on the MPCs DB25 plug, also no continuity while directly checking the fuse on the mainboard. I have ordered a remplacement part and will keep you updated on how things work out once I have relaced the fuse !
User avatar
By Harmoncj Thu Mar 26, 2020 5:49 pm
I do not know if this helps but when I mounted a PCD-25 in the 2000, IIRC, even though you can technically access the first partition from computer, it would not boot by copying the OS from PC. I specifically remember having the MPC open with powering both the floppy drive and the SCSI drive so that I could copy OS from the floppy.
User avatar
By hok-2 Sun Mar 29, 2020 11:58 am
I use a 1gb Sandisk.
Mpc2000's only reconise disks of up to 900mb's I believe.
So not much point in using a sd card larger than 4gb - as you can only have 4 seperate devices/vertual drives.
I just use one card, 1gb to keep it simple.
Aything over 1gb is expecting a lot from a 32mb machine made in the 90's :lol:

Here are the settings I use to set up the SD card with the scsi utility program.

scsi2scsi utility settings:
Enable scsi target - yes
scsi id - 0
Device type - removable
sd start sector - auto
Device size - 900 mb
All other settings are left as defualt.

Then go to 'file' save to device and it will transfer it to the sd card.
Now put the mpc 'operating system' on to the sd card.
That should work.

I havent tried larger sd cards or creating partitions but, if you change the 32gb to 900mb's in the device size section it should work.
I'm pretty sure its the device size that is the problem.
Hope that gets you up and running.
By Shawnsick Thu Apr 02, 2020 8:31 pm
Well I have finally got it up and running this evening, it turns out that I had to wire the DB25 plug backwards as I was using a male DB25 connector directly on the board where a female connector is supposed to be used, luckily nothings got fried apart from the SCSI Fuse on the motherboard that I replaced with resettable fuse.

Thanks for all the help and advice, I'm new here but I will be hanging around ! :smoker:
User avatar
By richie Fri Apr 03, 2020 7:58 pm
Shawnsick wrote:I had to wire the DB25 plug backwards as I was using a male DB25 connector directly on the board where a female connector is supposed to be used, luckily nothings got fried apart from the SCSI Fuse on the motherboard that I replaced with resettable fuse.


Excellent news man, good going. Could you post a picture to possibly better describe what you mean? It could be of help for others who are confused or having issues with 5.1

Also great choosing the re-settable fuse. It's what I have used on all my S series samplers without hassle.

There is an idiot on eBay and Reverb spreading misinformation that re-settable fuses will cause faults with the way the SCSI bus works and suggests instead that you pay him to buy a burn once fuse instead. :Sigh: