Technical questions for the MPC2000xl and the MPC2000
User avatar
By G.C. Fri Feb 02, 2024 8:47 am
Hi,
I recently got an MPC2000 and I just bought a ZuluSCSI RP2040 Mini + SanDisk ULTRA micro SD card 64GB.
On arrival I followed all instructions about formatting the card the right way and setting up partitions with image files etc.
I can see the device when I go to the disk menu and I can load sounds from the SD.
The main issue I'm experiencing is a "SCSI Write error !!" message when I try to save stuff or format.
Also the OS is in the card and the mpc is supposed to find it when I boot it up, well it doesn't, so I still need to insert the floppy disk.
Can somebody please help me with this?
Appreciated

Giancarlo
User avatar
By synaptyx Wed Feb 07, 2024 3:07 pm
Hi G.C., I have a 2KXL, so I think things are slightly different, but check out Bootdisk and Chill for loads of help with the 2K.
I found this SCSI image ISO worked way better than any of the IMG files I tried:
https://bootdiskandchill.com/store/ols/ ... r-zuluscsi
It's free!

With the XL, and I'm sure the 2K too, you can only have 7 SCSI IDs of 1GB (or slightly less) so your 64GB card is going to have a lot of wasted space on it unless you use it for other things. And you need to pay attention to what SCSI IDs you can use, but that site has helpful info, so have a browse around.
I bought an 8GB sd card and put the Bootdisk and Chill images on the root folder of the sd card (card formatted to FAT32) and that's working for me.
Also remember that these old machines can only deal with filenames with 8 characters plus the three character extension e.g. KICKDRUM.SND Any more than that a you'll get the MPC 2000 confused! :)