New to the MPC production world? Got a music production question that's not really specific to any particular MPC? Try your luck here and get help from our experienced members.
By Swancho Fri Nov 06, 2020 6:35 pm
I just bought an Akai MPK mini MK3 and downloaded everything and followed the videos, but when I hit my pads they don't always light up in MPC Beats and when they do light up no sound is played. I also tried it in Reaper, my main DAW I've been using for 1.5 years now, and the drum pads work for like 2 minutes before the sound also just stops. I have everything set up the way I've seen multiple videos tell me to and I've read a lot of other people's problems and I can't seem to figure it out. I don't know what I'm doing wrong, but if I can't get help with this I'm just gonna return it and give up on MIDI keyboards and just stick with my 66 key keyboard since that's the only thing I can figure out how to work.
User avatar
By GuruVirus Tue Feb 02, 2021 5:49 pm
#1!!!: Forgot that this has to be done almost every time you plug in the USB to your controller. Go to Edit >> Preferences >> Midi / Sync. Then next to MPK Mini 3 at the top, click Master, Control, Track (All should be hilighted white/gray).

1) In MPC software: do you have samples assigned (drag one onto) the pad icons (when viewing Home mode; Ctrl + 1 on PC).

2) While in Home Mode, if you go to Midi Learn (bottom right; Ctrl + Shift + L on PC) and click Learn, at the top right do you have the midi mapping preset for the Akai MPK Mini 3 or MK II selected? Either one will work fairly well, but you will probably need to re-map stuff like I do (the MPK Mini MKIII does not have its own mapping; so dumb). So click Learn, then click on the pad icon, then tap the pad on the MKIII until a number appears on the icon of the pad on the screen. When a number is on there, the pad is assigned. Tap the other pads to understand their internal number assignment.

To give you an idea of how unreliable this is, I just tried to do it and it wouldn't register any of my changes during learning and the assignments are all off again. At this point I'm wondering if 2.9.1 just totally destroyed the MKIII's ability to be reassigned? I'm so confused now. I checked the MPK Mini Editor - mk3 and my assignments are still default. Also when I press a Pad it says the Pad Name on the little LCD screen on the controller so all of that is normal. Just MPC software is garbage as usual. Edit: see #1 at the top for the fix.