Exchange tips and tricks for the Akai MPC4000
User avatar
By Telefunky Wed Dec 14, 2022 12:51 pm
In that case it‘s very unlikely that TR2 is the culprit.
Probably the contrast pot is just worn or damaged (broken resistor path from age).
The display circuit board is very simple and solder flaws should be easy to detect.
(in case pressing the pot bends it a little)
Iirc there are 2 tiny resistors (together with the pot they seem to be a voltage divider) and then output goes into a LM 358 SMD opamp on the display circuit.
If that opamp is dead, the display stays dark, too.
(I‘ve killed mine when fiddling with the display cable, but this part has no mechanical connection to the board where the pot is located)

best of luck, Tom
User avatar
By Kalou Fri Dec 16, 2022 2:39 pm
i've had a bunch of 4000's in my time but the one in question is NOS so contrast knob should be fine.

will try replacing this tr2 resister. they should arrive soon (50 of them haha)?

what was the bridge solution you mentioned? i'm keen to do that as a temp fix just to check the actual screen works itself before the return window closes.

also wonder if this tr2 resister is the issue, what broke that. maybe not something you can answer. i don't know that much (read: very little) about circuitry.
User avatar
By Telefunky Fri Dec 16, 2022 5:05 pm
Even if it‘s NOS you probably don‘t know about storage conditions, let alone it‘s a 20 year old device. The resistor line (or the tap) inside the pot may be broken, or bent.
If I understand you correctly you don‘t dial a position, but press the shaft with just the right amount of force.
(I don‘t remember the pot‘s construction, but most of them can be opened)

TR2 follows TR1 and to me it seems they buffer/secure a clocked 24V line.
(so TR2 fails in case of a dangerous current)
The latter may happen with the ribbon cable, which has no guide against sideway movement. Mine had a really worn out end and while I tried to fiddle it in several times there must have been a wrong connection that killed the opamp on the display circuit.
(fortunately a cheap standard part and easy to replace)

Seriously... 1st check the pot before messing with TR2 ;)
(I don‘t remember which pins of TR2 were bridged, I‘d have to open my MPC and look)
TR2 either works or is dead. If you get light on the display it is definitely ok.
User avatar
By Kalou Mon Dec 19, 2022 6:29 pm
hmm, some doubt creeping in now that the tr2 is the cause of the issues based on what you just wrote.

so i know the contrast knob works fine (or at least worked) because when i got this 4K the contrast knob worked flawlessly with the original screen. it's only now with the replacement i'm having issues. but i've also got an extra old 4k screen with a line in it and when i try that one i have the same issue.

it's very confusing. as difficult as it's gonna be to replace the tr2 i liked the idea of doing that when it seemed the definitive problem culprit.

not to labour this but what was the bridge idea? if there's a way of testing whether the tr2 is at fault prior to taking the whole thing apart i'd prefer to do that!
User avatar
By Telefunky Mon Dec 19, 2022 11:22 pm
Kalou wrote:... not to labour this but what was the bridge idea? if there's a way of testing whether the tr2 is at fault prior to taking the whole thing apart i'd prefer to do that!

I have no idea about the bridging of 2 pins of TR2... actually I was quite WTF when detecting the wire. I bought the machine because it had an Adat expansion, but the seller claimed he never used that (lack of Adat gear), and so it was sold as is.
Of course Adat and all digital connections turned out deaf when at home (as described in the deaf digital io thread), which lead to a full disassembly of the unit etc etc.

The bridge was likely made by someone experienced, but there‘s a reason for TR2 following TR1 and I wouldn‘t like to animate anyone to copy the hack and eventually cause more damage just to save $10 for a transistor (incl shipping).

One can access TR2 quite well when the top of the MPC is removed or tilted far up.

Serious Warning: the metal on the PSU is under high voltage (assume 2-4kV) and the path of the current may have a high potential of fatal shock, even with power off.
(there are loaded caps buffering energy)
User avatar
By Kalou Fri Dec 23, 2022 5:17 pm
wow, that's a bummer. will have to read that thread. hope you solved it (and got some money back)

i think you may be right and the contrast knob connection may be the issue. opened it up and beyond unsoldering / desoldering i'm not sure what more i could so. want to take apart the plastic of the top of the contrast control but wary of breaking it.
User avatar
By Telefunky Fri Dec 23, 2022 9:28 pm
The seller was a nice chap and I fully trust him (I picked up the machine locally).
He probably had the 4k for just a short period of time and sold it to finance another piece of gear.

Of course it was a bit annoying that my personal main feature failed initially, but I accepted the challenge and „learned to love the bomb and stopped worrying“ :mrgreen:
I still don‘t know what exactly woke up the digital io (incl Adat), but gear > 20 year of age may react strangely one day and you better learn the tech details anyway, which just happened earlier in this case.

I‘m glad I bought the 4k and re-discovered a couple of great sample collections which already helped me a lot to improve my (admittedly humble) bass skills. To be continued...
User avatar
By Telefunky Fri Dec 23, 2022 11:04 pm
I thought you already had exchanged a display... :hmmm:
Anyway: I didn‘t do a full disassembly of the screen as pictured in the service manual.
If you remove the 2 screws on the top back of the display, you can lift and tilt the display to the front. Put it on some foam or similar. The possible distance depends on the ribbon (I don‘t remember if it was fixed originally) and a wire fixed by a screw in the bottom left.
The ribbon is tricky to grab from behind. Check if you can drag it up without force (there‘s enough ribbon inside, but it does some angles and is fairly stiff).
That way you can put the display face down on the foam and have enough space to remove the screws on the back for further disassembly.

If the display ribbon is completely fixed you have to remove the top metal and function key cover to remove the bracket that secures it. I don‘t remember if the bracket was only a guide or if it clamped the ribbon.
In any case be careful when dragging the ribbon up (pulling some of it from the inside of the machine).

The pot (VR400) has 5 pins: 4 and 5 are main ground, 1,2,3 are the effective resistor.
You may check functionality with any 10kOhm pot soldered to 1,2,3 by wires (f.e. 3 lines cut from an IDE flat cable) with the pot away from the circuit. Log or Lin pot is only a matter of dialing convenience.
The construction is unshielded then but should do the contrast job.
If all works well you can order a proper replacement.

best of luck, Tom
User avatar
By Sense-A Thu Jan 12, 2023 1:40 am
The contrast knob is a vulnerable part that sticks out. It is soldered to the display board at 5 points.

If applying pressure to contrast knob makes the screen go on or off, then likely the solder joints to the contrast knob are cracked or intermittently sending signal.

The solution is to open the display portion of MPC 4000 and solder in a replacement contrast knob.

Also, I recall finding replacement ribbon cables that connect to the mpc 4000 display in case yours is damaged.

Oh, and there is also the possibility that the two boards inside the LCD housing are sometimes touching each other causing a short because of the way they are stacked, or there is a bad grounding issue inside the LCD housing.
User avatar
By Kalou Tue Jan 31, 2023 12:37 pm
just wanted to check in to say thank you for this response and advice.

i've had the 4k opened up prolly since i took those pics but haven't had a chance to work on it. did unsolder the contrast knob from the display board so hoping some new solder on it will help.

interestingly it's very difficult to get off the plastic knob. i don't want to force it (also done think it's related to this issue so probably pointless).

thanks again both for your help / thoughts. will get on this soon and report back!