Exchange tips and tricks for the Akai MPC4000
User avatar
By 27b Wed Feb 27, 2019 7:36 pm
I recently received an MPC4000 via UPS. Upon first receiving it, there was no sound from the outputs at all (headphone or main outs). I disassembled it completely, reseated everything and that fixed it. The FX card, however, seems to be bad. It shows as installed, but no FX work.

Upon further testing, everything else was working fine. However, midi output B started acting funky. My synth (DSI mopho) on output B started acting crazy, changing programs and hanging notes. I hit the midi panic button and that stopped it. That was the last time the port worked.

I connected the midi port to my PC and monitored its traffic with midi OX. It does not send note on/off or any usual midi traffic. If you mash a bunch of notes at once, it will pass some odd unrelated midi control messages, but that's it. All the other 3 output ports work fine.

I reinstalled the OS, re-initialized settings, etc and nothing changed the behavior. Thinking that the FX card could be the culprit, i disassembled everything again and removed the card completely. The issue is still there.

Anyone had a similar issue? I am pretty stuck here.
User avatar
By 27b Tue Mar 12, 2019 3:23 pm
just wanted to follow up for the archives

i fixed this problem by disassembling all the boards, cleaning the contacts and re-seating everything. all midi ports are functioning properly.

i have come to the conclusion that many of the odd problems on the 4K are caused by the connections between those boards that are sandwiched together. shipping via UPS seems to shake these things up just enough to cause these intermittent problems. it's easy to disassemble and reassemble everything if you go slow and pay attention to what you are doing (take pics along the way).
User avatar
By JUKE 179r Wed Mar 13, 2019 9:34 am
Good to know.
I've purposely bought a lot of broken/non-working/parts music gear on eBay for cheap just to get it home, disassemble it and find loose wire connections needing to be reinserted and BAM! it's working again.
Easy, peesey... :smoker: