Exchange tips and tricks for the Akai MPC4000
By Dillionaire_ Sun Mar 07, 2021 6:44 am
Still at a brick wall apart from this machine atleast running.

1) clock is scattered changes on its own on menu

2) took the internal battery out and its fixed that

3) tried disconnecting boards and running machine but can't get any audible noise

4) samples load into machine and inside I can see there is sound outputting, just can't hear it.

5) no sampling is happening from cds or direct ins.

6) feel like it's another DAC issue. Similar to the last output board I had.

Will keep trying, my next idea is to replace ceramic fuse on PSU, it just seems like the whole output board not getting any power.
By Dillionaire_ Tue Mar 09, 2021 11:39 am
Sense-A wrote:If you get to wits end and give up, sell it to me As Is.

I have enough parts to thoroughly test it, isolate the problem, and ultimately fix it. I have one MPC 4000 I already repaired and another one I'm in the process of repairing.

Hopefully, you get it working, though.


Thanks for the offer, I'm at the point where I've put so much time and monwy into it there's no going back lol
By Dillionaire_ Thu Mar 11, 2021 8:39 am
Pulled the ribbon off the HDD and CD drive that connects to mobo and noticed a hole through one of the wires inside the ribbon. No idea how that could of happened.

Can't understand how it would stop the output being non existent but it's a possibility. Looking for a replacement and will update.
By Dillionaire_ Wed Mar 17, 2021 7:21 am
Replaced 80 pin ribbon cable, everything runs exactly the same, not sure how a hole through one would not be a problem lol.

PSU is noisy when pressing buttons which was something new, will try take the psu out and have a look underneath it incase anythings playing up there.

Still my only issue is that there is no sound what so ever and everything is outputting to the LR channels

In the menus when sampling the output, the machine can see there is noise being generated but I cant hear it.


Clock is all funny, wont set, jumps from date to date and cant change clockrate from 44.1khz. Tried all i know this far but will keep going