Post your views and questions about the Akai MPC2500
By ThomasZZ Sun Jun 10, 2018 3:07 pm
Hello everybody,

My mpc 2500 (128 ram, jjosxl) is having some frustrating problems lately. I tried looking it up on the web but couldn't find an answer, I hope some of the Mpc Heads around here might have the answer!

Whenever I'm working on something the mpc starts to mess up my program settings. For instance I go right (or left, any direction) with the cursor buttons in the program menu and all the settings start to get messed up. Samples change, out, pan, fx, etc. Everything gets scrambled.

I've made this video as an example :

This is extremely frustrating, it basically makes the mpc unusable. If anybody has some insight on these issues, please let me know!
The complete guide to learning the MPC2500
User avatar
By Psychedelic Schizophrenic Sun Jun 10, 2018 9:27 pm
I would try some basic steps first like reinstall the OS maybe it got corrupted when installing. Also have you tried reseating the ram? Might be worth taking the ram out to see if its causing the issue. Once you done the basics and can rule them out then it's time to look deep in the machine, it could be that your data wheel encoder is getting stuck and glitching causing the random changes in settings etc.
By ThomasZZ Mon Jun 11, 2018 12:28 am
I've tried the ram option but that didn't work. How do you actually do a good reinstall of jjosxl, first remove the while thing down to the free version? There are plenty of threads on how to install but not on how to Reinstall..
Thanks for replying though!
By ThomasZZ Mon Jun 11, 2018 2:18 pm
Found it already! (sorry for being lazy :)
I did a clean install going back to the free jj and then on to the latest jjosxl 3.56
Everything is working as it should again, I guess last time I did an update I didn't remove the usb cable correctly.
That said, I believe the proper way of removing the cable from computer (I use windows) is by removing the cable from the mpc first!
Tnx again for helping
User avatar
By Psychedelic Schizophrenic Mon Jun 11, 2018 8:00 pm
No worries glad you got it sorted out. I don't the USB port its slow as **** being USB 1.1, I do all my transferring using a CF Card and a USB card reader like the one pictured below


You can pick up one for next to nothing and it has a much faster transfer speed over the MPC USB port. Seriously if you do need to remove any USB device then always use the "safely remove hardware" function on Windows, a friend of mine learnt the hard way when he just pulled the USB on his external HDD out of his laptop, corrupted the HDD and lost everything that backed on there :Sigh:

All the stress, hassle and upset of losing personal stuff that mattered to him for the sake of saving 5 seconds by not ejecting the device safely. ... -your-data