Post your views and questions about the Akai MPC2500
User avatar
By QuickStrike Tue Aug 13, 2019 6:58 pm
Hey guys just acquired a used MPC 2500le. I don't know if during shipping something got messed up or the unit was already malfunctioning.

I'm using the latest JJOs os2. everything works properly for about 10 minutes and then the suddenly the lcd gets fuzzy to where I can't read the screen and eventually completely goes blank. (Just green screen) The unit still plays and operates as normal. just I can't see anything on the screen until I reset it.
I used the new screenshot feature to see if it would work when screen was blank. It did, I loaded it up in my computer and it showed everything that was displaying on the unit. I just couldn't see anything on my actual screen.

Has this happened to anyone or does anyone know how to fix this? Any suggestions or answers will be helpful.
User avatar
By saltmcgault Tue Aug 13, 2019 7:10 pm
QuickStrike wrote:Hey guys just acquired a used MPC 2500le. I don't know if during shipping something got messed up or the unit was already malfunctioning.

I'm using the latest JJOs os2. everything works properly for about 10 minutes and then the suddenly the lcd gets fuzzy to where I can't read the screen and eventually completely goes blank. (Just green screen) The unit still plays and operates as normal. just I can't see anything on the screen until I reset it.
I used the new screenshot feature to see if it would work when screen was blank. It did, I loaded it up in my computer and it showed everything that was displaying on the unit. I just couldn't see anything on my actual screen.

Has this happened to anyone or does anyone know how to fix this? Any suggestions or answers will be helpful.


Take off the faceplate and make sure the ribbon cable that connects the screen is secure. It might not hurt to deoxit the connectors. If all else fails I have a screen I could sell you for a decent price.
User avatar
By QuickStrike Tue Aug 13, 2019 7:59 pm
saltmcgault wrote:
QuickStrike wrote:Hey guys just acquired a used MPC 2500le. I don't know if during shipping something got messed up or the unit was already malfunctioning.

I'm using the latest JJOs os2. everything works properly for about 10 minutes and then the suddenly the lcd gets fuzzy to where I can't read the screen and eventually completely goes blank. (Just green screen) The unit still plays and operates as normal. just I can't see anything on the screen until I reset it.
I used the new screenshot feature to see if it would work when screen was blank. It did, I loaded it up in my computer and it showed everything that was displaying on the unit. I just couldn't see anything on my actual screen.

Has this happened to anyone or does anyone know how to fix this? Any suggestions or answers will be helpful.


Take off the faceplate and make sure the ribbon cable that connects the screen is secure. It might not hurt to deoxit the connectors. If all else fails I have a screen I could sell you for a decent price.

So You think it's lcd?. Like the connector to the screen. Also how much would you sell me the LCD for. Inbox me. But first I'll try that I have some deoxit already.
User avatar
By saltmcgault Tue Aug 13, 2019 10:04 pm
My guess is that its the LCD screen. I'm sure there is some heads in here that probably might know more. It isn't going to hurt to make sure the ribbon cable and connector on both ends are clean and connected properly. Have to tried messing around with the contrast? hold shift and turn data wheel I believe. Also I think you can flip the color too hit mode + pad 10 or 11 "other" and you should be able to hit the F keys to move around in that section and there should be an option to flip the color to reverse. I cant remember if the green screen can do that or not. Its worth messing around with it. If all that fails I could sell you mine or buy a another one or....put that money towards getting the XLCD screen its way worth it I think but I believe you would have to upgrade on the OS.