Post your views and questions about the Akai MPC2500
By FlightRisk80 Sun Dec 30, 2018 12:56 am
Hi guys, I’m new here, so I apologize in advance if this isn’t the right forum to post this question.

I have a MPC2500 and have been having an issue with the analog input gain. When I run my turntable, CD player, iPod, etc INTO the analog input, even with the gain turned all the way down, a LOT of sound still comes through. I replaced the right pcb board thinking it was an issue with the knob, but it still does the same thing.

Now, I was trying to search around for some other information on what the prob could be. Only thing I can think of is maybe replacing the ADDA PCB Board, which has the 8-outs, and the analog inputs on it.

My question is, before I keep dropping money on boards, does anyone else know of anything else I might be able to try/test to help isolate the issue? Right now, the problem isn’t terribly pertinent to fix as I can always run everything into a mixer first and THEN into my MPC, however I prefer to run directly into the MPC to reduce any additional noise.

Anyone have any ideas?

Thank you in advance for your time.
User avatar
By selecta jo Mon Dec 31, 2018 1:03 pm
welcome to the forums!

what do you mean with "a LOT of the sound comes thru"?
is the sound slightly altered or exactly the same as your input source?

if you can hear your input source thru the mpc outputs while in the recording screen:
-> mode -> pad 5 -> record, then check the field in the right top corner that says "monitor" - if it says "ON", then move the cursor there with the arrow keys and use the data wheel to turn it to "OFF". Now check if you still can hear your input source thru the mpc.

if you can hear your input source while in the main screen or in the mixer screen then go to -> mode -> pad 8 -> mixer and there push the F5 button or use the "input thru" button to get to the "input" screen directly. In this screen "input" look at the top left field where it says "input thru" - if this field says "ON", then move the cursor there and switch it to "OFF".

Now you should not hear any sounds from your input sources thru the outputs of the mpc. But be aware that you now also don´t hear your sources when doing a recording or setting the reording volume unless you monitor your sources elsewhere e.g. a mixer where they might be connected to.

have fun!

peace, jo