Forum to discuss all matters relating to the MPC1000 and MPC2500 operating systems created by 'JJ' (all versions).
User avatar
By JeriKo Jackson Sat May 24, 2014 1:07 am
I posted this in the JJOS bugs sub-forum as well. I could really use some insight here.

Have had this issue since I first installed OS-XL. I thought updates might correct this but they have not.

Mode + pad 11 or Mode + pad 4

after entering either of those modes and then pressing main, Flash Rom Error is displayed.

after that pressing mode + pad 3 results in "Flash Rom Write Error" and the machine freezes.

This is not cool. not being able to use the loop recorder and then saving is a serious headache!

I have tried reinstalling JJ from scratch, going from stock akai OS, to JJ free, to XL... even tried OS3 which gave me the same issue. What's going on with my Flash ROM :hmmm:

Any other suggestions or help would be greatly appreciated.
User avatar
By JeriKo Jackson Sat May 24, 2014 1:18 am
From JJ:

"This is a problem of flash ROM and is not a bug of OS.
It happens that flash ROM sometimes cannot do writing.
Also when OS is updated, an error may sometimes be displayed.
Since this is a problem of flash ROM, it is unfixable.

Thank you."

User avatar
By bliprock Sat May 24, 2014 4:01 am
hardcore problem you have. I would consider opening it up and having a look to double check there is nothing foreign on the board or looks blown. Sounds like blocks are corrupted in the ROM chip set, so being ROM maybe forat, or similar is your last chance if your in the US
User avatar
By JeriKo Jackson Sat May 24, 2014 1:48 pm
Yeah this is wack! I am in the states after moving back from oz! So at least shipping to forat is feasible.

Although I have opened this and previous mpcs more than I can count, I'm not sure what the rom chip looks like. Also I'm thinking that if I send it out for repair they will just replace chip and I would have to buy JJ all over again. Is this a reasonable assumption?
User avatar
By bliprock Sun May 25, 2014 2:38 am
SMD is not impossible. I did some SMD pots only this week. Tricky yes but not impossible, depending on the pin count and of course ROM chip set would be much harder to, so really a job for very the experienced and some tricks. Probably turns out cheaper for mother board replacement though. I would maybe send MPC stuff email enquiry and receipt to JJ to show you have new ROM maybe but that is just an idea and you can not expect it to work. But yeah you are right to assume a new ROM means new code for unlock on OS.
Good luck.
User avatar
By JeriKo Jackson Sun May 25, 2014 4:18 am
:nod: Thanks for the info bros...

from JJ:

"A password will be lost if exchanged in flash ROM (motherboard).
However, a new password will be sent if it can prove that you exchanged flash ROM.
Please send the copy of the check certificate of a store which can prove having exchanged flash ROM.
And please send new Product ID.
Let's send a new password, if exchange of flash ROM is checked."

TSI Repair is authorized by akai and is located 20 mins by car from me. What's going to be worse the cost or being without my mp for however long? :cry:
By djestouff Sun Nov 12, 2017 3:54 am
Did you ever resolve this? Had pretty much the same issue on my 2500 for the first time today. I, too, recently switched to a 2500 after using OS2XL on my MPC 1000 for years.

I hit mode+Pad 3 to save a beat I started and got the Flash ROM Write Error, MPC froze.

Turned it off and back on and got the Flash ROM Write Error display during boot up, and again mode + Pad 3 crashed it.

I reinstalled JJOS 1 and the MPC seemed to work fine. Then I reinstalled OS2XL (seemingly) successfully, turned it off and back on. Got the error again during start up, crashed on mode + Pad 3.

I was getting pretty worried at this point, seemed like my MPC might be 'bricked'.

Up until this point I was using a 16gb flash card. I read somewhere to try using the stock 2gb card (which I don't have, but I did have a slower speed 2gb card). I copied the JJOS files from my 16gb card onto the 2gb card, reinstalled JJOS 1 and then OS2XL. Still got the error at boot up, still crashed when I went to mode + Pad 3.

Finally, I re-downloaded the OS2XL file from the JJOS website, loaded it onto the 2gb card. Reinstalled OS1, then OS2XL again and this time it was able to boot without error, and save without error.

I'm sad that I lost the beat from today, but it's not a disaster as long as the MPC still works..

I will update if the problem comes back..
By richie Sun Nov 12, 2017 10:39 pm
It's the internal flashrom of your 2500 that is bugging out. Have you tried going back to the stock Akai OS first?