Forum to discuss all matters relating to the MPC1000 and MPC2500 operating systems created by 'JJ' (all versions).
By Paradigm X Mon Dec 06, 2021 11:57 am
My PC used to read my card fine via a bilt in reader; in fact thats how i got the os3/2xl files over. i also backed up a load of files from mpc to pc hard drive; great.

Ive not tried for months but i inserted the card yesterday and PC says it must be formatted.

obviously dont want to format it and lose everything from the last few months.

i didnt reformat after installing os3 it still has years of data on.

the card itself seems fine loads saves fine on the mpc.

is this a pc problem? or an os3 problem?

anyone know how to fix it at all?

or how im best going to back up old stuff and reformat the disk so it works on both?

mpc1000 if relevant

many thanks
User avatar
By NearTao Mon Dec 06, 2021 12:04 pm
I doubt it is an MPC problem if it is reading the card fine. JJOS doesn't do anything to change the format of the CF card.

Things I'd look into. Try a different computer. Try the CF card in a card reader instead of over the USB.

It is possible that there is something corrupted on the CF card that the PC doesn't like, but that the MPC is fine to work around. If you are able, I'd look into ways to backup your data from the CF card so that you can try and keep your projects in case the card fails.

Good luck!
By Paradigm X Mon Dec 06, 2021 4:42 pm
hey thanks for the reply.

its not over usb at the moment; its like a floppy drive cf/sd card reader built into my pc (im not very good with computers). I forgot you can use usb; as a pinch i can copy all the important stuff then format it and try again and recopy everything back across. most of the new stuff is just in projects. ill see how long it takes to copy everything via usb. but thanks that will/should at least back things up.

thinking about it i might have formatted the pc and reinstalled windows since i last used it (i dont use pc often cant remember exactly when i last used it for the cf card) but it all worked fine last time. i havent got another pc with a cf slot or a usb cf reader. ill see if someone at work has one.

By Paradigm X Mon Dec 06, 2021 5:52 pm

i tried one last time for the millionth time and... it seems to work now (?)

Windows said it needed to repair it, which it did, and now seems to work fine again. Ive honestly tried that for several hours, restarted pc etc, but for some reason it worked. Its about halfway through copying everything to the pc now as another backup.

thanks for your help!