Forum to discuss all matters relating to the MPC1000 and MPC2500 operating systems created by 'JJ' (all versions).
By skdj Mon Sep 22, 2014 7:45 am
stan steez wrote:
Q: How can I delete samples stored in the Internal Memory (like stock sounds or whatever)?

A: ............... . In OS 2, the internal memory doesn't seem to be accessible any longer (at least in version 1.18).

Can somebody expand on this please. does this go for JJOS2xl also? if my MPC 1000 wont allow me to load or even see internal mem from load/save screens in 2xl & if i Tap Tempo + Power back to free jjos 3.16 it would look like this...

Is that normal with JJ OS2xl.??

also looks like this guy a page back has same question i don't see an answer.
joeybanana wrote:Hi i cant acces the internal Memory anymore since JJOXL. is this normal? Because i like to add some sounds from the internal Kits but cant load them since internal Memory window is empty
User avatar
By Bugfix Mon Sep 22, 2014 4:43 pm
after little check seems to me that
a) your internal memory is wiped out so if you left something there.. forget it
b)you can try load Akai OS as this will free up the space hold by os2/os2xl but I don't guarantee you will get anything from there, as it was probably overwritten by new OS..

Personally I would go option "a" :nod: :mrgreen: :smoker:
By manman Sat Nov 22, 2014 9:23 pm
Hey all,

Did a search for this but couldn't find anything, so sorry if this has been asked before. I downloaded jjos2xl from jj's site and am trying to install it over the free os ver 3.16. Looking at the instructions here and on the site it looks like you should just be able to save the install file to the card (so in my case mpc1000_xl345.os2) and select it from the load screen. But when I try that the mpc doesn't show the file anywhere on the card. I can see all the other stuff on the card but not that file. I tried putting it at hte root level as well as in a subdirectory. Also tried using the 'update from AkaiOS' method of powering on with window button. It said "A correct OS file was not found".

I've already played around with saving/loading stuff from CF card, and everything else has loaded fine, so I don't think it's a problem with the card/reader. Any help would be appreciated, thanks!
User avatar
By Eduardo.Macias Tue Mar 17, 2015 5:10 am
Man i can't believe JJOS1 is 60 bucks now :(
Looks like im really late to the party, I'll have to wait a few weeks till i can afford it. :cry:

Currently using JJOS FREE version. This one is already much more intuitive than the AKAI stock one, so now i cant wait to see how much better it gets with the paid versions!
By crushnmonk Thu Apr 16, 2015 5:44 am
I've read through the list and saw someone had something similar, but it doesn't quite answer my situation.

I recently picked up a MPC1000 quite cheaply. I was pleased to see it came with JJOS 3.08 installed - which I believe is the save-disabled free version.

But when I go to the save menu, I can save everything - samples, programs, songs! What's going on? I was expecting to see a product code, but I get a save menu! (powered off and loaded evertything back, so it definitely saved!)

Am I going crazy, or did the previous owner hack the firmware or something? :hmmm:

oh odd: the manual says saving is enabled : <<read somewhere it was disabled - hence "free"

okay : next problem, in [MODE]+A3 (Save menu), hit [MODE]+A3, and I don't see a product code, which I'll need to upgrade to a different version.

EDIT :oops: Disregard everything above :oops: . I've been reading about upgrade paths etc for weeks and confused myself. I think I have it sorted! Flash in the OS you want to purchase and THEN get the key. Man,....
By kropotiili Fri Jul 22, 2016 3:32 pm

I know this is probably stupid question, but I don't want to lose the JJOS. I bought MPC2500 where is JJOS XL 3.44 installed, can I install new 3.52 update and it still works with the same license? Also is there some place where I can download older versions of JJOS XL or can I save it from JJOS? I tried to save it in MPC but it saves only .sys file not .osx.



By kropotiili Fri Jul 22, 2016 7:56 pm

One question more, how can I apply effect (example reverb) to the whole track, not to one pad at the time, is that possible? If I'm using program where I can add one sample and use external keyboard to play it, how can I add reverb on that?



Byanon_8948337878 Mon Oct 24, 2016 8:04 pm
Howdy there. New MPC 1000 owner here. I was reading the FAQ and saw something that may need to be updated. I have been researching JJOS for a while now and intend to purchase JJOS2XL quite soon. On JJ's site it is not mentioned that OS1 is required to install OS2XL (the free OS is, of course, required). It reads like this on JJ's site:

The price of a password is US$123.00.
However, the price is US$74.00 when OS2XL is installed in MPC into which the password of OS1 was entered.
Moreover, the price is US$15.00 when OS2XL is installed in MPC into which the password of OS2 was entered.

So it appears that you can now install OS2XL without installing OS1 or OS2 first, giving OS2XL its own price, and this is reflected in the installation instructions as well, which only requires the free OS to be installed: