Reviews and questions about the entry-level MPC500
User avatar
By mr_debauch Mon Feb 13, 2012 6:59 pm
hey I need to get a copy of one of the older OSs (1.31 is installed now on the said machine) anyhow I need a copy of one of the old versions (was it 1.13?, I am not sure) but the US and japan akai site doesn't seem to have anything but the latest ones available to download.

let me know if you can upload it or if you know where it can be obtained (here in the thread or via PM)
User avatar
By mr_debauch Wed Feb 15, 2012 1:35 am
awe man, thanks jibber for the effort though.. I appreciate it. Yeah it's because a friend of mine had an old project made on the OS that came with the 500 when he bought it in 2006 or something like that.. anyhow I updated the machine for him not thinking:

1) he had old projects that weren't recorded to his pro tools on his mac, and

2) not thinking the projects made on the old OS would not work on the new one... usually akai makes their stuff backwards compatible (I can load mpc60 os2.12 HD floppies up in the 2000 classic just fine)

my friend had the mpc for a long time but never really dived into it until last year.. then I went and screwed things up for him (on one project) however still the new OS offers much improvement.. they should update the 500 for damn sure.
User avatar
By Ill-Green Wed Feb 15, 2012 4:26 am
Oh man, I spent two nights now looking for those old threads for the old OS but they all come to OS 1.31. :?

Still, I don't think you'll recover the old files simply by installing the 1.13. Its like a digital brainwash for these little guys and once you install them, they'll forget what they did last time they were functional. Did the demo songs got deleted too? If not, then the files could be hidden within the compact-flash card. :idea: Just trying to help out. We all screw up :)
User avatar
By mr_debauch Wed Feb 15, 2012 5:20 am
no I dont think the stock demo or autoload garbage is gone... the problem is, when he tries loading up I believe it's the sequence file... he gets a cpu error or some **** like that... he tells me he still has the sounds at least as far as I know...
User avatar
By Ill-Green Wed Feb 15, 2012 6:37 am
mr_debauch wrote:no I dont think the stock demo or autoload garbage is gone... the problem is, when he tries loading up I believe it's the sequence file... he gets a cpu error or some **** like that... he tells me he still has the sounds at least as far as I know...


Oh, the programs and sequences got the axe then. Thats cool but not all bad news. As long the compact flash wasn't corrupted, he'll be good.

Since I have both 1.13 and 1.31 500s, let me tell you the difference is night and day. Jog wheel is more accurate, no crashes YET, and the OS is more stable. The save and load options are kind of a joke because they're both in the same menu, Akai should've made one button for them like hold MODE and press SAVE/LOAD key instead of having them seperate. You did him a favor really, he should have known to make a back-up though.

On the bright side, its a portable sampler on batteries, with the sounds, he can recreate his tracks during lunch-breaks or while waiting for the little lady at the mall. :P
User avatar
By mr_debauch Wed Feb 15, 2012 7:06 am
Ill-Green wrote:
On the bright side, its a portable sampler on batteries, with the sounds, he can recreate his tracks during lunch-breaks or while waiting for the little lady at the mall. :P



yeah that is what I think I will tell him to do.. he could maybe fix the song while he's ducking from some crazy broad he hit a few days ago hahaha..
User avatar
By JUKE 179r Tue Jan 29, 2019 9:15 am
I remember back in the days if you wanted any older or beta files for AKAI, Yamaha and Roland products you just went straight to their main Japanese website to find it.
That doesn't work anymore. :WTF: