Reviews and questions about the entry-level MPC500
User avatar
By audiomastertronics Wed Apr 20, 2016 12:53 pm
HI,
i recently bought a AKAI MPC 500 with faulty midi.
I did all general tests..it seems midi is completely dead.
I would like retro upgrade for check if something change.
I can't find a copy of old os in all WEB.
If anyone have an old copy of AKAI MPC 500 OS 1.11 OR 1.12 OR 1.13.
Let me know where i can find it?
If you want to send me the bin my address is:
marion_crane84@yahoo.it
Thanks
Max
User avatar
By audiomastertronics Wed Apr 20, 2016 2:09 pm
MPC-Tutor wrote:http://www.mpc-forums.com/files/MPC500/mpc500v130.bin

Thanks for 1.30!
Now the midi is back to work!! but not correctly i think..there is a bit of lag when you play from keyboard and akai mpc 500 play the single sound.
It seems is not a problem of hardware.
I read differents threads and many people have similar problems..
mine model was made in malasya..maybe every different hardware version have midi bugs with the upgrades?
Thanks,
Max
User avatar
By RobS Thu Apr 21, 2016 12:26 pm
I have some OS lying around, but I don't know which one is it...

But the filesize is smaller than both 1.30 and 1.31, so it's probably older than that.

I've sent it to OP's email. If anyone wants to have it, reply here or PM me.

EDIT: i've found out it's actually v1.13

EDIT EDIT: While trying to google 1.11 and 1.12, I've found 1.13 online here:
http://www.bignoisempc.com/downloads/
By marc marc Fri Jan 25, 2019 12:13 am
Hi everyone !
I have exactly the same problem but the 1.30 doesn't completely fix the problem so can someone send me an older OS ? i'm getting crazy looking after it on the internet, it's impossible to find !!!!
And did the person who opened the subject get the bug fixed ?
thank you !
User avatar
By DjDiskmachine Fri Jan 25, 2019 9:44 am
marc marc wrote:Hi everyone !
I have exactly the same problem but the 1.30 doesn't completely fix the problem so can someone send me an older OS ? i'm getting crazy looking after it on the internet, it's impossible to find !!!!
And did the person who opened the subject get the bug fixed ?
thank you !


Did you try RobSs version?
RobS wrote:EDIT EDIT: While trying to google 1.11 and 1.12, I've found 1.13 online here:
http://www.bignoisempc.com/downloads/


Downgrading OS versions seems like a very harsh solution to a MIDI problem like this as you expose yourself to more bugs. Did you try factory resetting / check your MIDI settings?
By marc marc Fri Jan 25, 2019 11:50 am
hi !! thank you for anwering.
The link Robss posted is no longer available...when i click on download it goes back to the homepage of the website...
And yes i tried everything about parameters (i think).
On the 1.31 version, when MPC 500 is the master, i press play and the slave (a jomox 09 drum machine) just run for a few steps and stops. If i try to stop and start again, it will only work once for ten tries but will always stop after one second. When MPC as slave, it doesn't start with the jomox and from time to time, tempo goes on -EXT- but then goes back to the initial 120...
So i tried to install the 1.31 OS again (i didn't use my mpc for a long time before yesterday) and when the installation finished i pressed play and...the jomox started for like 5 seconds (it played the jomox pattern a few times) but then stopped and did like before....
SO, i though about changing the OS to try, who knows ? And guess what? When i installed the 1.30 version the midi got better : know the Jomox starts and keeps playing when i press play on the MPC ! BUT there is a lag : the jomox stops from time to time on a random step (very often actually) for a few seconds and then starts again (from the step it stopped on) so it remains unusable as midi master or slave.
That's why i'm looking for an older version of the OS. It looks like it is a software problem more than a hardware problem. Can someone help me ?

thannnnks !
User avatar
By DjDiskmachine Tue Jan 29, 2019 6:46 am
I read from your description of the problem that you've attempted using it as a clock master / slave. How about MIDI notes / CC messages?
Do you get dropouts / lag for these messages too?
How about MIDI thru, what happens if you send clock, note, CC messages Thru the MPC to another device?

I'd use a MIDI monitor to get a visual readout of the messages going in and out. For macOS there is one called simply MIDI monitor, for other OSes use your favourite search engine.
It sure seems appears to be a SW issue, but since this seems to be a reasonably rare problem I wouldn't be so quick to jump to that conclusion.