Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
By Novae Wed May 15, 2019 1:23 pm
Hi.
I'm using MPC Studio Black with MPC software 2.5 on windows 10.

When i'm in PROG EDIT, i choose a pad an select the first INSERT and then an effect, lets say Reverb Medium.
I don't see how i can edit this effect for this particular pad on the hardware.

Like it say in the manual, i should be able to press"Window" and see the parameter. But nothing is happening.

Someone have an idea ?Image

Image
User avatar
By Monotremata Mon May 27, 2019 4:11 pm
Ahhh I was wondering this last night while working on something. I was opening them in the GUI and they would pop up on the Studios screen. Didnt even know this was a thing until I used a couple of the delays last night. The Window button Ive found doesn't really do anything at all heh.
By Mystic38 Mon Jul 08, 2019 1:26 pm
yup.. I have just got the Renaissance on win10 with 2.5 and just discovered this also.. I cannot control the insert fx parameters from hardware despite the manual being clear about this being the method ..

This was particularly confusing for me since this is exactly how the mpc5000 works..lol
By Mystic38 Tue Jul 09, 2019 12:19 pm
So, I am totally confused as to how to use the fx on the Ren with 2.5 via the hardware and not sure if it is even possible...

Here is a more full account of the fx with the Ren on 2.5, at least as far as i can see.. and i would be very happy for someone simply to say I am doing something wrong.

1. You can assign an insert fx per pad via hardware but cannot adjust any parameter of the fx..either via hardware or the software.. (note: the software does not even show/recognize that you have added an insert fx )

2. You can assign a send fx in the hardware, and you can even control the parameters of it, however it does not seem possible NOT to have the send fx affect every pad in the program.... you can adjust the send amount UP from zero, and increase the FX amount per pad, but zero is not, well zero... (if i am doing something wrong here let me know)

I simply do not see how the fx can be used in the ren via hardware like at all ..and hope this is simply user error, so i hope someone can put me straight?..

thx!
By Mystic38 Tue Jul 23, 2019 1:38 pm
ok..so I am talking to myself.. yes, you are..he says, but read this if confused.

INSERT FX via RENAISSANCE HARDWARE!..

NO, insert fx via hardware in program edit window, as expected and as stated in the manual DOES NOT WORK. period.. i made it to page 22 of the manual "lets just add an effect to a pad" before i crashed and burned..lol

However , I just d/l 2.6 to see if this bug was fixed, and it isnt..

BUT i took another approach, and went through the PROG MIX screen and here, yes it works..you can add multiple insert fx per pad and access the fx control parameters..

hope this helps someone else as for me its a major headache gone :nod:
User avatar
By Monotremata Tue Jul 23, 2019 6:00 pm
Yeah it looks like this is all screwed up heh. Im in program edit right now, added one of the LP Filter Sweeps on the Studio itself. The effect shows up, I can set the send level and the effect is in fact on the track but... The GUI in the software doesn't respond to any of the controls on the hardware, but it IS taking effect when you change something. Even the Q-Link send controls dont move. The only thing that does actually work is the SEND column on the hardware. I can see the send knob on the track itself moving but thats it heh. And uh yeah that Window button doesn't work there either. I got it to open a couple of plugins yesterday just fine but it doesn't close them again..

EDIT: Ok weird still.. While the hardware showed I had the LP Filter Sweep on insert 1, I decided for kicks to actually add it in the software itself. It removed it from the display on the hardware, but showed in the software. When I clicked on it, of course the GUI popped up and THEN it showed up on the hardware again. NOW on the hardware you can go to the plugin and Window will open the GUI. Oddly enough, if you're in the SEND column on the Studio and hit Window, it opens up the Keygroup editor asking you how many key groups you want to create??? Umm Akai??
User avatar
By Monotremata Thu Jul 25, 2019 7:13 am
Dang wouldn't let me edit my post, been too long haha.

Anyways, I posted over at the Akai forum earlier about this. It DOES work but its another case of them changing the terminology after everything has already been printed (including the silk screening on the Studio/Ren hah). PROG MIX is now what is called PAD MIX, and TRK MIX is now PROG MIX. I think I remember seeing this in one of the 'whats new' lists for one of the older updates but never paid attention to it. And yeah the Window button DOES open both Pad and Program inserts, but you have to be on the actual Mixer screen for each one to do it. For whatever reason, the page in Program Edit is just to add it and set the send level, it wont open the GUI from there.

The Q Link issue is still the same though. When you change the send, the Q Link display doesn't update unless you use the actual Q Link knob to change it. The send level goes up and down just fine, but the display never updates. AND to top it all off, if you do use the Q Link after you've set the send level, it resets back to 0 with the knob.

I actually had no idea the Window button did everything it does until yesterday too. Every time I grab the manual to look something up, Ive been reading the Software manual. I just noticed there's a separate MPC Studio 2.6 guide on the help menu in the software. What do you know THAT one shows you how to use all of the Studio. I couldn't find it anywhere for download on Akai's site, even in my own account. Only the software guide. Luckily you can save the PDF from the software. This whole time I never even knew I could do Detect BPM right on the hardware as soon as Im done trimming and chopping in Sample Edit. Found a bunch of cool stuff it does last night, Ive been jumping back and forth to the computer to take care of. Things just got that much quicker now.
By Yerbalist Sat Aug 03, 2019 7:40 pm
Hi there, just learning this machine. Bought it as a expansion for my mpc500, that lacked fx and propper arrangement section.
Indeed, this is terrible bug not to be able to change FXs parameters. When Im trying to add any insert to pad, the WINDOW button lit but not responding :Sigh:
Its a bad thing as my workflow is based on effects in electronic music, switching to my laptop every time.
However, the automation page works (the right bottom from the main) but its only for progs
Hope AKAI solve this ASAP
User avatar
By Monotremata Sun Aug 04, 2019 7:26 am
See my reply above. It DOES work but you have to be in the pad mixer or the program mixer to do it. It wont open the effects if youre in Program Edit on the Effects screen. Im not sure if this was intentional or a bug, but at least it does work on pads if youre in the pad mixer and go to the Insert tabs. Its too bad the Close button on the hardware doesn't actually close the GUI on the computer screen though heh.
User avatar
By Monotremata Thu Aug 15, 2019 4:49 pm
Ahh I wondered about that, I noticed that when I was trying it before I replied above.. So it DID work at one point then! I played with the software back in like the 1.8 days for a bit and by the time I actually bought it with the Studio, 2.5 was the current one so I missed alot of the stuff that used to work that just doesn't anymore heh.