Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
By bo:em Mon Jun 24, 2019 1:38 pm
Hi! After one week trying to get sound out of my mpc ren I think that I don‘t fix this by myself. Maybe anybody got a similar problem?

I‘ve bought a new IMac (Mojave) because my MacBookPro (2008) is getting old with 8gb Ram.

First I‘ve installed the MPC-Software (1.9.7) and deinstalled the driver. Then I installed the driver 3.3.11 for mojave but all I got is buildinsound in the System/Preferences and in the software. The Ren also is not available in Audio/Midi but showed up in Midi/Studio with the IAC-Driver.

Deinstalled everything and installed again but no chance. The interface isn‘t available anyware. I‘ve tryed every USB on the IMac and also a USB 2.0 Hub because i was reading some problems in forums with that.

Don‘t want to buy a new audiointerface and hope anyone can help me.

Thanks and greets BO
By dryad-66 Wed Aug 14, 2019 6:47 am
Yes i just got a new/old macbook with High Sierra OS,loaded MPC 2.6 and ren driver 3.3.11 and works as controller but no audio in outs available!!!!! Waiting for Akai to get back to me but they said that maybe it wont work (REN) with High Sierra and Mojave (??) Any body know about this?? I also read somethin on the web that maybe the earlier REn driver might work?Any info would be great.
User avatar
By Monotremata Wed Aug 14, 2019 7:30 am
Weird you installed 2.6 and nothing?? This happened with 2.4 and 2.5, they left out the security check so the MPC doesn't request access to the audio inputs when it runs the first time. We had to go back and install 2.3, and then update to 2.5 to get it to work. I installed 2.6 from scratch when it came out and it had the security pop up the first time I opened it.

If it never gets access, it will just act like nothing is happening when you select the audio inputs. I think it should still show up as an interface in Audio MIDI Setup though!
User avatar
By Monotremata Wed Aug 14, 2019 7:08 pm
They have older ones for the Studio up on the Studio's project page in the Download's section, maybe theres one for the Ren there too?? The only way to get the newest version is to install the MPC Software heh, if you download it on its own, the Studio's driver is still the original 1.0 one.
User avatar
By Monotremata Thu Aug 15, 2019 12:34 am
dryad-66 wrote:Yeah i got the latest one.Just read its worth trying the older one.Seems like there not supporting the Ren " [


I hope they still are, maybe theyre making a new black one? Id kinda like to get one if I find one for a steal. I don't know that I would use the audio interface on it but man it would make working in the software so much more awesome with the full size one hehe. Id use the **** out of the Q Links for sure. I use em alot now but since 2.6 they changed the stupid direction the knob moves around the 4 banks and I STILL cant commit it to memory!
User avatar
By Monotremata Tue Aug 20, 2019 1:16 am
Just curious, was it SIP you had to disable? I had at one point both the 1.0 and whatever updated driver the 2.5 software came with for the black Studio on my system. When I noticed it in Apple System Profiler, the old one was unsigned (or something like that) and Mojave said it couldnt load it. Apple's done ALOT of **** security wise in the last 2-3 years so yeah watch out with those old drivers. I never ran into any issues because when I bought it 2.5 was out so it so it installed the newer driver that did load. They were named differently which is probably why the 2.5 installer doesn't overwrite or even see the old one.