Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
By BeatSneaker Wed Oct 16, 2013 12:13 am
I just wanted to share this with Mac users who have been having trouble updating the MPC Renaissance firmware to v1.10 so that they can get the best experience out of the new v1.5 MPC Software.

If you've seen my previous posts, you'll know everything I had done previously to get things working had failed - BUT - then I had an idea...

What if I used Boot Camp on the Mac to set up a Windows 8 partition and then tried updating the firmware that way?

Guess what? It worked like a charm!

I set up Windows 8 on the Mac using the latest Boot Camp installers, then installed the MPC Hardware driver and software from the supplied disc with the Renaissance. After that had installed, I ran it and selected "Check for Updates". The v1.5 update appeared and I downloaded, installed and ran it. I was then told that the Renaissance firmware was out of date, so I clicked the link and downloaded it.

Once downloaded, I followed the instructions and a little while later, my hardware successfully updated to the the v1.10 firmware!

Image

Finally, after over five days of trying, I've managed to find a workaround that actually does work.

I then rebooted the Mac into OS X 10.8.5 to check all was okay.

Image

As you can see, everything is now as it should be.

I know everyone reading this might not have a Windows 8 OEM disc to hand, but as a user of FL Studio 11, I luckily did and used it to solve this issue and hopefully next time, Akai will come out with a Mac firmware updater that works...
...for EVERYONE!

:-D
By BeatSneaker Wed Oct 16, 2013 12:23 am
DJ Hellfire wrote:I wonder what this issue could be. First some were saying Windows only, now you are saying you had issues on Mac. I'm on Mac and it took me less than a minute for the firmware to update, while some guys have spent days with it! Weird! :hmmm:


True, it's crazy!

I've read people failing to update with MacBook Pro's (I'm using a 15-inch Retina MBP), but then having success with iMac's! Maybe it depends on what version of OS X you're running? Who knows?

At least this workaround actually worked (at least for me) and I hope anyone else who is able to try this gets success too.
User avatar
By JAH Wed Oct 16, 2013 12:30 am
I've installed the firmware running OSX 10.8.5 without any issues. But the process takes time and you are not suppose to interrupt the update once it begins even if it appears nothing is happening....
By BeatSneaker Wed Oct 16, 2013 12:48 am
The problem was the hardware wasn't responding for me, it just sat there and did nothing! Only one pad lit and the lights around the Q-Links didn't flash.

Doing the update from Windows 8 via Boot Camp was totally painless and it worked first time with no errors at all. I wish the Mac updater was as good, but there's obviously issues which need fixing.
User avatar
By JAH Wed Oct 16, 2013 1:09 am
I can't call it. I followed the instructions exactly and updated without any problems on my Mac Mini. But I acknowledge some here have had issues. Of course there is no what people are doing at home.

After reports surfaced that customers were having difficulty updating the firmware, Akai released additional notes/instructions on their website.
By dutch Wed Oct 16, 2013 2:42 am
I updated on my mac no problems and pretty quick I might say.
By master-ceo Wed Oct 16, 2013 3:05 am
The first build worked fine for me as well.

2011 MBP OSX 10.8.5

Remember to close all open programs and unplug all other USB devices.
By BeatSneaker Wed Oct 16, 2013 8:00 am
I followed the instructions exactly as Akai instructed.

This is what I did after disconnecting everything attached to my Mac:

1. Ran the firmware updater app with the Renaissance attached and powered on.
2. Removed the USB cable from the computer and turned off the Renaissance.
3. Plugged the USB cable back into the computer.
4. Powered up the Renaissance while holding down 'Shift'.

When I did this, the Renaissance display is blank (lit blue) and just one pad (Pad 1) is lit in yellow.

5. I then clicked "Start Update" (while still holding down 'Shift' on the Renaissance).

Then a box appeared.

1. It told me to let go of the 'Shift' key on the Renaissance (and I did).
2. It told me to turn off the Renaissance (which I also did).
3. It then told me to wait 5 seconds (which I did).
4. Then it told me to turn the Renaissance back on (which I also did).

The Renaissance display then showed "MPC" as normal, with no pads lit.

5. Then finally, it told me to click "OK" and start the update (which I did).

I can see the update being sent via the software indication bar on the updater, but nothing happened on the Renaissance hardware at all.

The firmware updater app then said:

"The update has been sent. Please check your device for update status. You may need to restart the device for the process to complete".

I turned the Renaissance off and on again and ran the MPC Software.

The MPC Software told me to update the firmware as it's still at the original version.

I just bought the MPC Renaissance last Thursday, it's brand new!

However, after loading the MPC software onto the Boot Camped Windows 8 partition on my Mac, the Renaissance did respond, four pads were lit and the Q-Links flashed as the firmware was received by the unit.

I have no idea what the issue is with the Mac firmware updater app, but after five days of trying and getting nowhere (until setting up Boot Camp on the Mac), there obviously is one and I'm sure that Akai are well aware of it and are hopefully working on a fix!
User avatar
By JAH Wed Oct 16, 2013 8:15 am
I have a 2nd Ren which I haven't updated the firmware. Within the next day or so, I will provide step by step details on what I did to update it.
By tonemelle Thu Nov 07, 2013 11:47 pm
My MPC Studio firmware still hasn't updated after multiple attempts.
My Studio and DAW are acting somewhat glitchy..
Akai is driving me up the wall with this. I put up with both the studio and the REN for a year and I never have had such a hard time producing records because of these silly little flaws that interrupt my work flow.
These products are becoming a major letdown for me and I've been an AKAI supporter since I made my 1st beat years ago. The REN & Studio can NEVER beat the popularity and stability of the Maschine if they (AKAI) don't turn things around over there ASAP...
I'll hit up the ppl in AKAI for more assistance but this (on top of the other weird unexplainable things the REN & studio do) is really getting ridiculous right now...

even the process of updating has a work around for it?!?!?!? WTF ever happened to just simple updates smh??