Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
By emjayess Fri Oct 25, 2013 6:02 pm
[Note: I tried to send a message to Akai support online, but the "Submit" button never worked. Go Figure.]

After updating the MPC Renaissance software yesterday, when I opened it up for the first time, it indicated the firmware needs updating; however, the firmware update is not working. While holding down the "Shift" button, it gets hung up at the "Locating the MPC Renaissance..." stage.

I believe I have followed all the prepare instructions.

Any help on how to get the firmware updater to work will be greatly appreciated!

Thanks!

(FYI: I'm using an 2011 iMac with OSX 10.8 Mountain Lion.)
By nickponcho Tue Nov 05, 2013 8:26 pm
I think i've found the solution!!! YAAAAAAAAAYH!!!!

1. Start the MPC Software in 32-bit mode.
2. Run the MIDI Update Tool and follow the on-screen pop-up instructions (in the new installer) and when it tells you to restart the device, do the following.
3. Close the MPC Software
4. Turn off the MPC hardware
5. Turn on the MPC hardware
6. Start the software (tada, now go check the firmware version under preferences - hardware - show hardware info)
7. DONE!!!

THink it was the 32-bit mode on the MPC software that did the trick...

Wish you all good luck!! (I've contacted AKAI support but no answer, went to the local reseller and found out that I got guarantee left, but i thought i would give it some more tries before i send it to akai in Sweden, and boom it worked)
User avatar
By dantuf Wed Nov 06, 2013 10:49 pm
My Ren was stuck on the locating mpc bit and I just unplugged the usb lead and put it back in without turning it off and it worked fine from there..

on windows 7 64bit..