Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
User avatar
By producer0187 Fri Jun 16, 2017 8:02 pm
producer0187 wrote:So, after banging my head against the wall, de-registering the software with Akai so that I can sell the Ren on Ebay, but never getting around to doing so....I may have found a solution to this problem. It's worked for me for four days now with no issues (noise, static, etc.) for hours at a time.

I went to Wally World and purchased a 2.0 USB port (cheapest they had went for $11), came home, plugged and played...NO ISSUES NOTED TO DATE! Can't be that simple...right?

I never wanted to get rid of the Ren and now it doesn't look like I have to. Give it a shot if you haven't already and report back with what you find.

Oh btw, I'm running the MPC software on an iMac, 2.7 GHz Intel Core i5, 8GB of memory. I haven't tried it on my Windows 10 laptop yet but I'm almost willing to say it'll work there as well.

P0187


Just wanted to post a pic of what I picked up from Wal-Mart. Still rolling...NO issues. $11 bucks...plug and play.

Image
User avatar
By Marcelo Checoni Tue Dec 05, 2017 2:40 am
Hello, I am back to tell you that I finally solved the latency problem. I installed the USB 2.0 PCI Express card to create an exclusive USB bus/hub to hook the MPC Ren and it is working now. It is difficult to understand if the problem was caused by the incompatibility with the hybrid USB 3.0/2.0 bus from my PC's motherboard or the bandwidth of the bus itself, that was shared with other USB devices. The fact is that this product solved the problem: https://www.amazon.com/gp/product/B002R ... UTF8&psc=1

I bought this model because I needed a low profile board for my SFF Lenovo PC but I am sure that any other USB 2.0 board will do the trick. Thank you for your help.
By JEFFMAN90 Tue Jan 15, 2019 4:52 pm
I'm also having the same issue with the Ren. My desktop has both usb 2.0 and 3.0 ports. I always plugged in my Ren onto the usb 2.0 ports. Also I tried disabling the usb 3.0 from bios but that also didn't work. Akai needs to fix this ****.