Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
User avatar
By tayo Tue Oct 17, 2017 4:42 pm
Brought my Ren to the house for a home set up. Tried to use it as my main audio interface with my 2015 mac book pro . Lots crackling when I tried to sample so I tried changing the bit accuracy and latency. Now it barely works. Shuts down mid session and my mac wont even acknowledge it as an interface which sucks cause I cant preview any samples before using them. When I try to click on the audio icon in my mac preferences i just get the pin wheel. I reinstalled the software and did a pram reset. no luck. I have the same issues running logic thru it. :WTF:

Any insight would be appreciated.
By funkycoldmedina Tue Oct 17, 2017 11:24 pm
I also have a 2015 MBP. Same problems for me. Have not found a solution. Tried everything. I just stopped sampling in because it's not even possible without all the crackling. So yes, this interface ain't sh*t.
User avatar
By tayo Wed Oct 18, 2017 4:47 pm
Lampdog wrote:People on the forums here have had alot of issues with usb 3.0 hubs I remember reading.


I'm using a 2.0 hub but it doesn't seem to make a difference.
User avatar
By tayo Thu Oct 19, 2017 5:17 pm
I love it. Theres no actual help on here still. we just come to vent i guess.
User avatar
By TheUnfuckwithable Thu Oct 19, 2017 5:49 pm
Just use a dedicated audio interface and call it a day. Nukai audio interfaces (and everything else) = ****^10. Do your research and you´ll find out...

Any other questions? I am here to help!
User avatar
By Living Bate Thu Oct 19, 2017 6:34 pm
tayo wrote:I love it. Theres no actual help on here.


The reality is the unit is probably coco shunted and needs to be fixed

The other reality is the cost of fixing the thing will probably not be too far off the price of buying another one
By ntalec Thu Oct 19, 2017 9:20 pm
tayo wrote:I love it. Theres no actual help on here still. we just come to vent i guess.

You have 3 basic options:
1. Get a different Mac that has been verified or switch to a verified PC
2. Get a quality POWERED USB 2.0 hub
3. Get another audio interface to use

Unfortunately you purchased a Mac believing the myth that they have no problems which isn't true.
This is not just a problem with only the Ren interface other interfaces from other vendors have also experienced issues with certain Macs.

Whether you run a Mac or PC you still need to look out for combinations that don't play well together.
By SILIS101 Thu Oct 19, 2017 11:52 pm
I have a 2015 MBP. Get an audio interface. I use my NI Z2 mixer, works perfectly. I set my Z2 as the input and output.
User avatar
By otobot Fri Oct 20, 2017 5:59 pm
When I had the Ren, the only way to get it's audio interface to work absolutely crackle-free was to disable the generic USB3.0 driver - the one for the motherboard. This was on a PC laptop.
I had to reinstall Windows for that and explicitly NOT install the USB3.0 driver since disabling it afterwards was not possible in my configuration.

With your Mac I guess it's worth a try to find a way to disable USB3.0 completely - if that's a possibility.. I'm no Mac guru.
User avatar
By MPCWeapon1 Sat Oct 28, 2017 11:18 am
tayo wrote:Brought my Ren to the house for a home set up. Tried to use it as my main audio interface with my 2015 mac book pro . Lots crackling when I tried to sample so I tried changing the bit accuracy and latency. Now it barely works. Shuts down mid session and my mac wont even acknowledge it as an interface which sucks cause I cant preview any samples before using them. When I try to click on the audio icon in my mac preferences i just get the pin wheel. I reinstalled the software and did a pram reset. no luck. I have the same issues running logic thru it. :WTF:

Any insight would be appreciated.


I’ve had issues using the REN with my 2015 MBP. The USB/Thunderbolt adapter works but can be temperamental.

I had a old 2008 MacBook Pro laying around and it runs the REN perfectly. So I use the old 2008 model for for the REN, and the newer MacBook for the Studio.
User avatar
By tayo Tue Oct 31, 2017 2:33 am
Just a heads up y'all. I updated my os to the most current one and now it works. If I listened to y'all I woulda had to buy a new computer, new interface and new Ren. Lol

Thank for the replies tho.
By ntalec Tue Oct 31, 2017 3:59 pm
tayo wrote:Just a heads up y'all. I updated my os to the most current one and now it works. If I listened to y'all I woulda had to buy a new computer, new interface and new Ren. Lol

Thank for the replies tho.


Which proves it was your computer not the Ren.
If Apple would have fixed the problem sooner then the suggestions wouldn't have been the solution but they were.
High Sierra was just released meaning most haven't even touched it yet to know that Apple actually fixed something instead of just breaking things as usual.