Bug reports & end-user support for Akai's MPC Software 'controllers' including the new MPC Studio 2, the MPC Touch, MPC Renaissance & original MPC Studio and MPC StudioB lack.
User avatar
By tsutek Mon Dec 17, 2018 7:53 pm
I got fckd by High Sierra too so spent a weekend reinstalling Sierra and all my software. Thank the gods everyhings working again.

If you are unable to install Mojave, stick to Sierra. If You update High Sierra beyond 10.13.2 you will be SOL
By themixtape Sat Aug 22, 2020 7:46 pm
Bought one used. Could NOT get it to work. Windows 7, 64-bit.

Followed the installer instructions to the letter (restarting after EVERY step). Nothing. All it showed on the screen was an extension of my desktop wallpaper.

I did everything right. Every single thing. I spent two solid days uninstalling, reinstalling.

Every time the USB cable was connected to the computer (the final step), driver installation failed. "Akai Professional MPC Touch"... failed every time.

I disabled Digital Signature blocking, too... which was the cause of the problem... or seems to be. Still, would not install.

If anyone knows any tip/trick to get it working with Windows 7, please let me know. I googled everything and found nothing helpful.

I even tried newer versions of the DisplayLink driver... nothing worked. Nothing.

I'm happy with my MPC Studio. I just would like to try the workflow with the Touch, as I never tried it or the Live before.

By KoraZ ACP AKS Sun Feb 07, 2021 12:56 am
I have an MPC LIVE and I use to hace other MPCs. Sure that they are many things that could be better or simply, could be.
But, you talk like a hater. Looks like AKAI put a gun in your head or the **** your wife. Is ridiculous to post things like this. The MPC LIVE is a revolution. 4 hours of battery. You never have something like this, a complete portable music center.
AKAI does not listen their costumers. But in those new machines they change the game.
Since I have the LIVE, I do not use my computer to create music.
Is only my point of view
By 610FFM Thu Dec 01, 2022 5:14 pm
Simple solution:
Do not use audio over the MPC Touch!

It's a controller, which "happens to have" an audio-output.
Who would use a keyboard as their main audio-device?

The sound-output of your main-board via mini-jack sounds probably better anyway.

Works perfectly on macOS 10.14 and above, and up to 10.13.4
If you use 10.13.6 it will not work because USB-display-mirroring was changed by Apple.

On Windows you might have to disable XHCI (USB 3.0) in BIOS completely to make it work, which means you'll lose all USB 3.0 connectivity or have it switch back to USB 2.0.
Otherwise your USB devices will re-initialize in a loop.

I'm using it with macOS 10.14.6 and on Windows 8.1 / 10 / 11 without any trouble...