Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
By ZacharyWayne Fri Jun 21, 2019 8:38 am
To the point. Plug in my Focusrite Scarlett 2i2 and my MPC Touch. Go to preferences to choose an audio input in the MPC software (which is up to date) and no matter what I choose, it says “Audio device not working, audio will not be processed”. I have deleted and reinstalled the audio drivers and nothing works. USB cables are fine. Everything works great if I attempt it in garage band, just not the MPC software. Even I choose built in microphone on my Mac as an input to the MPC software it gives me that message. Help!
User avatar
By Monotremata Fri Jun 21, 2019 5:18 pm
Weird but you said Garageband is working ok?? I know there's an issue with the installers after 2.3 and MacOS and the security settings. With High Sierra, you have to start allowing software to access the audio inputs. When you run an app for the first time it will ask you for permission to use the microphone and you have to tell it yes or it cant use the inputs at all. I started right at 2.5 so I didnt notice it until the day I actually wanted to sample something with it. I found the answer here, but I had to uninstall 2.5, install 2.3, run it once so I could allow it access, then upgrade back to 2.5 and now it works. For whatever reason (theyre on a roll with this ****) Akai forgot to do this with the installers for 2.4 and 2.5 and the support folks act like they have no clue why its doing this when people ask about it on their own forum.

I never got any message about it not working though, it just doesn't respond at all when it does that. If Garageband is working, then that means at one point you allowed Garageband to access the inputs with it. You may just need to reinstall MPC 2.3 and upgrade from there. Akai unfortunately just updated their website last week so all of us who's download links used to say MPC 2.3 are now updated so we can only download 2.5. The Akai support folks have emailed people copies of 2.3 to fix it but if you need it I can upload it somewhere. Im not sure if thats allowed here or not, but its not like the Mac version is cracked so it won't do anyone any good without an iLok license hehe.
By ZacharyWayne Fri Jun 21, 2019 6:38 pm
That makes sense that I need to allow permission. I don’t remember doing that step. Will try and return with an outcome. Yeah everywhere I’ve searched every “expert” says it has to be cable interruption or a bandwidth issue among the various USB inputs but my Mac Pro has never had an issue like that.
User avatar
By Monotremata Fri Jun 21, 2019 10:01 pm
Yeah I was ready to start screaming when I couldn't sample with it here. They know about it, and 2.6 is coming here in a couple weeks so hopefully thats one of the things they've fixed with it. Thats just something that needs to be set in the installer, its not even the MPC app they have to worry about hah.

If you need 2.3 lemme know in the meantime. It SHOULD sort you out right away.