Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
By anthonyserra22 Mon Mar 30, 2020 2:10 am
I recently updated my iOS to Catalina a few weeks ago, stupidly not thinking how it would effect my MPC Renaissance and related software. Since upgrading I get no sound output from the Ren, and when I do get sound from my turntable thats connected to it it clips so easily. I don't believe Catalina is supporting the renaissance at this time.

Unfortunately I never backed up my comp so cant go back to the previous iOS using time machine or anything.
I miss making music. Anyone have any advice on what avenues I can take to remedy this? Any help would be greatly appreciated. Thanks so much.
User avatar
By NearTao Mon Mar 30, 2020 12:15 pm
Just a nit, but iOS is for the iPhone... Catalina is OS X.

If you're only going forward... you could install bootcamp, make your computer able to boot into windows... and then get back to work there. Otherwise, email/call Akai tech support and see if they have any suggestions?

You
By mmgh Mon Mar 30, 2020 3:56 pm
In contrast to IOS, it is quite possible to rollback your OSX to the version it shipped with or any version in between. No problem
By mmgh Mon Mar 30, 2020 4:52 pm
You basically need an empty usb stick, a terminal code (link provided by Lampdog) and disk utilities (cmd shift U) to format your stick. And of course the OSX you want to rollback to, which is available on the Appstore from apple for free.
User avatar
By Lampdog Mon Mar 30, 2020 9:06 pm
I’ve never had to do this on Mac but if I did the link I posted above would be the options I’d first try.
By eoneopdebeat Wed Nov 18, 2020 10:36 pm
Yoyo registered just to post this because it took me a while to get it working, wanted to share with everyone that loves their mpc as much as i do:

step 1: uninstall display link
step2: download legacy driver directly from display link website https://www.displaylink.com/downloads/file?id=1636 (supports catalina)
restart of course

go to the mpc installer, a green check mark should be beside the install display driver

i tried config screen, "turn display on" that didn't work, however after a reboot and opening the software (still the display didn't work), clicked through the settings... all of a sudden it just popped on...

i also turned screen recording on in security and privacy settings for displaylink

some of these steps might not be necessary, but this is everything i did

im on catalina 10.15.7

hope it works for everyone, i didnt find a solution anywhere else...
By Atxben Wed Feb 10, 2021 10:04 pm
confused as to how this helps use mpc with catalina. what does it have to do with displaylink.

what am i missing here...

eoneopdebeat wrote:Yoyo registered just to post this because it took me a while to get it working, wanted to share with everyone that loves their mpc as much as i do:

step 1: uninstall display link
step2: download legacy driver directly from display link website https://www.displaylink.com/downloads/file?id=1636 (supports catalina)
restart of course

go to the mpc installer, a green check mark should be beside the install display driver

i tried config screen, "turn display on" that didn't work, however after a reboot and opening the software (still the display didn't work), clicked through the settings... all of a sudden it just popped on...

i also turned screen recording on in security and privacy settings for displaylink

some of these steps might not be necessary, but this is everything i did

im on catalina 10.15.7

hope it works for everyone, i didnt find a solution anywhere else...