Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
By eoneopdebeat Sat Nov 21, 2020 11:05 am
step 1: uninstall display link
step2: download legacy driver directly from display link website https://www.displaylink.com/downloads/file?id=1636 (supports catalina)
restart of course

go to the mpc installer, a green check mark should be beside the install display driver

i tried config screen, "turn display on" that didn't work, however after a reboot and opening the software (still the display didn't work), clicked through the settings... all of a sudden it just popped on...

i also turned screen recording on in security and privacy settings for displaylink

some of these steps might not be necessary, but this is everything i did

im on catalina 10.15.7

hope it works for everyone, i didnt find a solution anywhere else...
By Lemmy Tue Nov 24, 2020 2:26 pm
Thanks, I am holding off upgrading from Mojave for now, but I will try that I have to move to Catalina.
By djtdk Wed Mar 10, 2021 10:49 am
I followed the post as tried several times and downloaded the same driver posted

Had to reboot a couple of times but when the display link agent was asking for access I checked that in privacy and rebooted and ran the installer again configure screen section and it works...


Catalina OSX 10.15.3
NEW: MPC 2.9.1 (MPC Touch)


Method

Remove old driver
install the legacy driver

Use the 2.9.1 Mpc touch download from Akai
check the settings for the display link agent are checked
make sure Mpc touch has access in the accessibility also
reboot and it will access it from a screen pop up

This was a pain but saved me buying a new drum maschine I would advise not to upgrade to latest versions of OSX until confirmed working in the Mpc community..

Peace TDK
----------------------------------------------------------------------------------------------------