Bug reports & end-user support for Akai's MPC Software 'controllers' including the new MPC Studio 2, the MPC Touch, MPC Renaissance & original MPC Studio and MPC StudioB lack.
By Zieg Warheit Tue Oct 12, 2021 3:52 pm
I have yet another issue with MPC touch, but was not able to find anything on this forum yet.
The screen connects without issues and I can see the desktop. Buttons also work correctly.
The problem is - when the MPC software is started - the touch interface is not shown on the screen. Also if I try to load the project - loading gets stuck until I disconnect the MPC Touch.
I have tried to press SHIFT + ERASE, but nothing changes or appears on the MPC touch screen.

Did anyone encounter anything like it?
By Zieg Warheit Wed Oct 13, 2021 5:18 pm
Yes, sure. Apologies for not specifying it from start,
OS is Windows 10 21H1 (Build 19043).
The Touch was bought used, but this was a showroom unit. Generally good as new, and interface was working fine on their MacBook.
MPC Software is 2.10.1 64 bit (I assume it is the latest for now)
Same issue can be reproduced with MPC Beats 2.10.0.

I can provide more PC specs if needed,
By Zieg Warheit Thu Oct 14, 2021 5:08 am
Yes, I have installed all the drivers according to the manual and video instructions on the AKAI site.
I even tried to install newer version of Display Link driver and reinstall my main video card driver as well.
But at this moment I am back to stock driver bundled with the installer.
It does not seem to be a driver problem since the display works and I can see my desktop and drag other windows there.
By Zieg Warheit Thu Oct 14, 2021 9:21 am
TL;DR: The issue was with windows scaling settings and native display resolution being too high.
Lowering the resolution and setting the scale to same 100% on all displays allowed the Touch interface to be drawn in correct position.

So after a 5 or so hours of fiddling with the drivers, display and compatibility settings I think I have managed to find the problem with my setup.

My main screen has quite high native resolution - 4500x3000, so I have interface scaling set to 150% at all times.
Touch screen runs at 1280x800 with 100% scaling.
While it does not cause any issues with MPC interface, for some reason it causes the Touch interface to be drawn outside the visible area of the Touch' screen.
I have tried to set scaling on all displays to 100% and it worked. The interface I now being shown correctly!
However due to high resolution of the screen itself - MPC is almost unusable and everything is super-small.
Then I have fiddled with compatibility and DPI settings for the MPC app - but I was not able to find a combination of settings that worked good - everything is either too small or too big and stretched far outside the screen boundaries.
In the end what worked was to set the display to a lower resolution (3000x2000) and scale it to 100%. Only in this case both MPC and Touch windows are drawn correctly.

I have submitted a bug report on that to AKAI, but do you know if there is anyone I can contact with this issue directly?
User avatar
By MPC-Tutor Thu Oct 14, 2021 10:11 am
Zieg Warheit wrote:I have submitted a bug report on that to AKAI, but do you know if there is anyone I can contact with this issue directly?


There's no one you can contact on a one-to-one basis for bug reports. some of us are public beta testers and can submit reports but generally speaking we can only submit a full report if we are able to create the problem ourselves, so it's best if you just submit it yourself via the form on their site or via the MPC Software.

But I would also point out that the MPC Touch is now discontinued and unsupported, it is very unlikely that Akai are going to do anything, especially as it's the display that has been the cause of all the Touch's problems and most likely the reason they've moved on from this method of UI management.