Support and chat about Akai's range of MIDI controllers, including the MPD. MPK and LPD
By redlexlucifer Fri Mar 04, 2022 3:18 am
Hello! I recently upgraded my MacBook and am currently sitting on an unusable controller. I noticed that people have been having issues with the USB connection but has anyone tried midi cables to a usb dongle rather than the USB-B cable? I just spent a butt ton of money and don't want to buy a MIDI to USB dongle if that doesn't work also. Seems really weird to me that this is even an issue. Hopefully someone will have some insight on this issue. Thanks guys!
User avatar
By MPC-Tutor Fri Mar 04, 2022 8:27 am
Could you elaborate on the issue in more detail? The MPK249 is USB class compliant, doesn't need drivers, so should be plug and play like any other midi controller (via a suitable USB convertor or cable). In theory a class compliant device shouldn't care what processor your computer uses.

EDIT: There are people who have it working no problem, sounds like you need to use a quality cable or experiment with USB hubs, the issue is likely related to the USB C conversion rather than anything relating to the MPK itself:

My wife has an M1 macbook, I'll try connecting my MPK249 to it later and see if I can replicate the issue.
User avatar
By MPC-Tutor Fri Mar 04, 2022 8:49 am
Okay just connected my MPK249 to my wife's Macbook Air M1 via a random brand un-powered USB C hub. She doesn't have any audio software on that computer but it's showing up in the Mac's 'MIDI studio' no problem (Applications > Utilities > Audio MIDI Setup > Window > Show MIDI Studio) .

It's definitely supported in M1 computers. I doubt you specifically need a USB hub though, a good quality cable should do it, USB C to B (often called a USB C printer cable). But YMMV. Here's the hub I used:

But it's now significantly more expensive than it was 2 years ago, it also interferes with the wifi on my iMac so I only use it with my iPad Pro these days. But it really is just a generic hub, nothing special.
By redlexlucifer Sat Mar 05, 2022 5:17 pm
I went and got a usb-b to usb-c cable. That didn’t work. I guess I’ll try to buy a powered hub. I even did a clean install on the computer. It is the newest 16” MacBook Pro with the M1 Pro chip so I don’t know if that’ll make a difference between the regular M1 chip. It’s just so frustrating because the MPK225 worked on it so I don’t really understand why the MPK249 wouldn’t.
By redlexlucifer Mon Mar 07, 2022 3:54 am
Just so everyone knows who sees this post, I was able to get the MPK249 working with my MacBook Pro M1 Pro on Monterey with a powered usb 2.0 hub I got on Amazon. I’ve seen some people saying they do and don’t get this to work so I’ll include a link to the one I got working. Hope this helps someone as frustrated as I was. Thanks guys! 4 Port Compact Black Hub ... b_ap_share