Support and chat about Akai's range of MIDI controllers, including the MPD. MPK and LPD
By Pbl4845 Mon Apr 10, 2023 1:24 pm
Hi all,

I have a known issue with my MPK49.
I have it since it was released.

It started to send random CC messages years ago. ….I “solved” the issue filtering out the CC messages in the DAW.

It became worse and worse , till the point I couldn’t use the sustain pedal anymore(or any other CC.

I have tried Vyzek app(on an old IMac) upgrading the firmware to 1.05 over USB, but SYSEx messages receiving over USB are stuck at 0%. ….as you know, firmware needs to be deleted prior to update.

Over MIDI, either on Vyzek or SYSEX Librarian do advance “finish”, both with 1.03 and 1.05 versions. Every time I tried it finished on an different number…..but it says “Done”, it does nothing if I click enter as the LCD says, it does not reboot itself as expected, and if I power cycle it, it boots with all the lights off, and not working over USB(didn’t tried over MIDI).
Only thing I can do is boot in firmware update mode(with 3 buttons pushed), delete the firmware again, and cycle start over.

I have tried several send speeds on SYSEx Librarian with no luck(only I noticed slower speeds made it stuck earlier without LCD saying Done).

Does anyone have any clue?
Did anyone upgrade the firmware successfully?
How the **** did you do it?

I have an Intel MacBookpro(Monterrey, no Vyzek), and an Old IMac (high sierra). I also have a MOTU MIDI Tiempiece AV, which I used to try alternative methods of upgrading.

SYSEx Files I’m using , I got them from here https://www.failedmuso.com/downloads/Akai_MPK.zip

It’s brick right now and I have no clue how to get it back even with random CC Messages an spread over different channels.

Please God Send any **** help!

Kind regards
pbl