Read the forum guidelines and post all your comments, questions and suggestions about
By Soundchaserz18 Tue Apr 27, 2021 2:23 am
Working on my MPC X ..about 3 days ago for about 6 hrs.....i go to listen to the tracks i started on the following day thru the headphones and i get no sound/audio output (meters are showing output)..So i connected my monitors...same thing no audio/sound or if i turn it up i get some distorted/clipping output of the audio being played...had the MPC X about 2 yrs... So i'm going to assume it's out of Warranty....I've turned it Off/On ..un-plugged it/ReSet it numerous times /re-installed firmware a couple of times...deleted some file from the Primary SSD (It was full/so i erased about 3gbs. of files) (Also, by accident some Demo files)....Still nothing...Really,Really hoping it's a Software Issue & not a Hardware issue...Also in Controller Mode same Problem....No Audio as a Sound Card or Full Volume Distortion/Clipping....everything else is working as should.....Thinking maybe i Triggered/Turned On something that i'm not aware of by accident.....Help
User avatar
By NearTao Wed Apr 28, 2021 11:56 am
Have you tried changing your program outputs to different 3/4 5/6 or 7/8, and hook your monitors to those outputs? They have no volume control... so might output, and could help narrow down the issue.

Also... you in standalone or controller mode?

What firmware/software version are you using?

If in controller mode, are you on Windows or Mac?
By Soundchaserz18 Sat May 01, 2021 4:10 am
I've tried both Standalone/Headphones & Controller Mode same issue.....Mac OS...i'll try changing from 3/4 5/6/ 7/8 output channels..haven't tried that yet....Thanks
By harleyheinrichs Sat Apr 29, 2023 9:57 pm
Any updates on this guys ??? I had the EXACT same issue on TWO mpc x’s. First one I got within the first month of their release, this same problem happened the first day I used it. They sent me a new one under warranty and then this one happened after about two years. Already tried changing the outputs, updating all softwares and firmwares. Exact same issue as described above
User avatar
By 83dude Sun Apr 30, 2023 8:11 am
This might seem obvious, but have you tried resetting preferences?