Share your knowledge on these two classic MPCs
By riley Thu Feb 13, 2020 6:40 pm
Hey all
I'm trying to get an MPC3000 format a card and it's not recognized, problem is similar to this:
viewtopic.php?f=4&t=168702

No card is recognized. The MPC3000 was purchased with Valixi 3.5 and the CF reader installed.
I've tried 3 different 1gb CF cards including a second hand Lexar model which someone on a Gearslutz thread specifically said had worked for them. All cards were inserted when unit was off.

The card reader has a green light on it which turns on if a card is inserted, but have not seen any indication of the card being read from. Always get "No SCSI device was found" when selecting FORMAT A SCSI HARD DISK option.

I opened the MPC up and checked the card connections.... everything "seems" in order and I tried disconnecting and reconnecting the molex connectors. But no luck.

I saw on the other post someone recommended replacing a fuse, not sure which on that is.

Anyone have any recommendations for next steps?
I've noticed pretty much everyone is using SD card readers now for the MPC3000, and I'd be willing to upgrade, but I don't really want to buy one of those if it could be another issue.

Thanks!
User avatar
By JUKE 179r Fri Feb 14, 2020 10:16 am
Welcome to the forum.

Has it worked before or is this a new 3000 you recently bought?
What brand of card reader do you have in the 3000? Take a pic and post it if you don't know.
Could be bent pins in the card reader.
Could be an issue farther up on the SCSI cable and the connections to the circuit boards.
Could be the SCSI fuse F901 is blown.
Image
Image