Share your knowledge on these two classic MPCs
By kraftywerk Wed Oct 26, 2016 1:13 am
I meant just to test, I plugged the power into the McDisk then connected the SCSI2SD card via 50-pin SCSI cable to the McDisk just to see if it would pass on the power. It did. But then when I connected EVERYTHING (using the multi-connector SCSI cable - meaning McDisk, SCSI2SD, and internal SCSI all going to the SCSI board) it no longer appeared powered.

Yes I have Vailixi. I'm not too worried about getting it set up right once it's powered. I was just confused about the power. I did a really quick format with the MPC so I might format it again once I have the power situation solved and will follow your guildelines. I think I formatted something like 32 8MB partitions on the disk or something like that. I know only "A"/hybrid will be available by putting the SD card in my Mac (via SD reader).

Do you have any idea why 2 wires would be snipped on the power cable? And do I need all 4 wires going to the SCSI2SD? Trying to figure out whether I have to just buy an entirely new cable (floppy 4-pin to 4-pin Molex) and solder it onto the MPC board or not. Thank you.
User avatar
By JUKE 179r Tue Mar 14, 2017 2:14 pm
kraftywerk wrote:Do you have any idea why 2 wires would be snipped on the power cable? And do I need all 4 wires going to the SCSI2SD? Trying to figure out whether I have to just buy an entirely new cable (floppy 4-pin to 4-pin Molex) and solder it onto the MPC board or not. Thank you.

It's rare but some card readers only accept the red wire 5VDC (and not yellow wire 12VDC) which is the same voltage advised for the SCSI2SD card if you don't use the SCSI bus power. Using the extra 12VDC yellow power wire will fry the components on the SCSI2SD card. I've seen it happen.
I added a v5 SCSI2SD card with a 2GB SD card and the RaizenMonster card reader in my 3000LE. Works great on Vailixi OS.

BTW... there is a new firmware update that came to for the v5 SCSI2SD card.
By kraftywerk Wed May 23, 2018 10:23 pm
I'm bringing this back up...I've had no luck making the SCSI2SD v5 work in my MPC3K (beige).

I was having problem with it internally. Powers and would show up as a disk, can browse the card but it freezes on saves and loads. It can sometimes do fast, small stuff, like sequence loads or saves. Samples? Forget it. It stopped working altogether and I changed the SCSI fuse. Started working in the same unreliable way. bought Michael McMasters 50-to-25-pin SCSI converter so I could hang the SCSI2SD off the back SCSI jack, where I knew the ZIP disk worked, just to eliminate doubt. Still have the same probs... The freeze usually manifests with the amber light staying on and everything stopping in that state forever until I power cycle.

Michael has been amazingly patient in trying to help. I tried the SCSI2SD v5 with my S3000XL and it seems to work properly. So I think it's the MPC. I'm super curious about those of you who have made it work. It's driving me crazy! Latest firmware 4.8 installed, slow SCSI host transfer speed enabled, multi-sector off, parity option enabled. I will say that I try to do hybrid partitions. Also, lately it started throwing out checksum errors and to stop using the disk I was using. I tried another SD and got the same issue. Have reformatted multiple times.
By richie Thu May 24, 2018 11:11 am
@kraftywerk, do you have Vailixi?
By kraftywerk Thu May 24, 2018 11:36 am
Hi Richie. Yes, I do have Vailixi in my beige MPC3K.

I'm sending a debug log to Michael (SCSI2SD) and we're working too, but he thinks it's just a very bad and non-standard SCSI host so hard to get reliable performance. I will post any progress with the issue here in case anyone has similar problems to mine now or in the future.
By richie Fri May 25, 2018 4:13 am
@kraftywerk the thing is that Vailixi's SCSI host was supposedly rewritten to resolve those issues from 3.10-3.12. Correct me if I'm wrong but from looking at your past posts, you haven't exactly had the greatest time with your SCSI stuff overall on the MPC 3000.

Since we have others on this forum that have used SCSI2SD with the 3K just fine (one person off hand is Juke179) what I am wondering is -- Have you tried using the SCSI2SD in an external enclosure? You know, just to verify that there isn't anything going on with the internal SCSI setup you have going on. I see you changed the fuse, what kind did you use? The resettable ones or the black n25?

Anyway, get back to me whenever. I'm just curious and hopefully we can come to a solution so others can reference this in the future man.
By kraftywerk Wed May 30, 2018 5:10 pm
Hey Richie. Great point and thanks for taking the time to look at my other posts. Agreed, SCSI's been a **** with any card reader, using the internal wiring. With a ZIP it's been fine. And I used a polyfuse to replace the original fuse. Like you I suspected the internal stuff, like the gender-changer and ribbon cable and internal SCSI adapter...especially since my external ZIP worked mine.

So re: external enclosure, I did an external non-enclosure! That is, I got Michael's adapter and hung it off the back like I did my ZIP...just sitting there bare on a piece of plastic ;)

BUT I have great news! (I am so cynical at this point I don't expect it to last!)

On this last round of tests, I had a major oversight...maybe someone can tell me where Vailixi stores its preferences (is it in something like flash, or is it on the media you use to store files?) because that will help me determine when and how I screwed up, but somehow the "Multi Sector Transfer Mode" was set to ON. I had set this to "OFF" long ago and made sure that was the case multiple times, but on this last round of tests and upgrading SCSI2SD to the new firmware, it somehow got set to "ON" again! Turned it off and it works, at least in initial tests (and very slowly) with these settings:

-SCSI2SD v.5 hanging off rear SCSI port with 26-to-50 adapter (powered by cable)
-4.8 firmware version
-"Parity" option enabled in scsi2sd-util
-"SCSI Host Speed" setting to "Slow". (From the don Michael McMaster: "This is a new option that can enhance reliability (and checksum errors) over poor cabling. The external SCSI cabling is often quite poor in terms of impedance matching and termination."
-"Multi Sector Transfer Mode" = OFF

Let's see how long it keeps working.

Now if someone could just tell me a part number for a drop-in replacement for the output jacks and sample input jacks, all of which have somehow cracked on my machine, I'll be in happy land...
By dumbeat Tue Jul 31, 2018 2:23 am
Any news on this?

Im shopping around for the best option for installing an internal CF reader and hated to know what's the latest on this front, What is the best way to go at this time.

Thanks!
User avatar
By JUKE 179r Tue Jul 31, 2018 8:05 am
Here are some tips from Chicken Systems to use the SCSI2SD in samplers.
It mostly pertains to use with their Translator program but hopefully it can help you out...
Chicken Systems SCSI2SD information
Chicken Systems SCSI2SD partition map
By dumbeat Fri Aug 10, 2018 6:48 pm
Hi-

I bought the kit. Got the SCSI2SD card v5, with an 8gig Micro SD card in it and an adapter ribbon for connection to the internal scsi port in the MPC3K Vailixi 3.5.

It wont recognize the SCSI2SD when connected internally.

However, i connected a DB25 cable that i have in my studio, normally an audio DB25, from the SCSI2SD to the external SCSI port on the MPC.

In this case it does recognize the SCSI2SD, but when trying to format the card, it reaches an error after about 10 seconds of saying "Formatting Disk".

I followed all the advice on this forum as far as how to set up the MPC in the DISK => 9 => 5 setup menu.

What i can conclude is:

1. The internal setup is NOT working, which makes me think that connecting directly to the SCSI board inside the MPC is not enough. The back of the external scsi port of the MPC has a few components on it's own card, When connecting into the MPC internal SCSI card we are in tact bypassing the External Port's own card. That makes me think that there is a component on that bypassed card that is required, and thats why all the internal storage solutions out there provide a special adapter card that has a few components on it in order to make the connection to the MPC scsi card.

2. Even when i DO get the MPC to recognize the SCSI2SD card, by hooking it up to the external SCSI port directly with a db25, as if it was any ol' external drive , it wont Format the disk, so this error has nothing to do with the connections but something else.

Needless to say the SCSI2SD is programmed to have 4 ID's, first i tried 4X2g and then i re programmed to 4 X 1g and then 4 X 830mb, just to see if that makes a difference, it does not.

Anything im not thinking of? Termination? Fuse?

Also just as a note, the SCSI2SD is NOT getting power from the scsi port. i need to tap power from the Floppy drive's Molex.

What are your thoughts?
User avatar
By bjarnir Sun Aug 12, 2018 3:03 pm
Hey dumbeat, i am also owner of a v5 scsi2sd drive. Ive recently tried it externally with an adapter from amigakit, and a male to male parralell dsub25 cable, . I also was able to see the devices on the mpc but was not able to format them unless it was set to a cd drive in the util settings for the scsi2sd drive you have like 4 options there for each of the four id’s. I was also able to save but when i turned the mpc of it was gone.
im running os 3.11 and ive read in some posts here that it wont work with the 3.11 os so I’m waiting for a 3.50 os now,
but have you set the multi sector transfer mode off? Just a thought , seen alot of users here posting it should be off for the drive to work
By dumbeat Fri Aug 17, 2018 11:40 pm
Hey bjarnir. Thanks. Tried everything exept the cd mode.
Already returned the scsi2sd this tne seller. Back to zips for now…

Can you link all tne items you have that make for a working setup? Thanks.