Forum for all other samplers including Maschine, MVs, Akai S & Z series, Emu, Roland, Yamaha, Korg, Boss, Ensoniq... and even Beat Thang.
By are- Tue Nov 13, 2018 11:27 am
Hi! I am currently facing issues with ASR-X PRO. When power is turned on there is a message "Asr-x os is invalid! Insert Asr-x os disk". I got 3.04 and 3.20 os disks, but none of those wont work with Asr. Any advice how to fix this issue? I got this sampler years back within another unit and I have not basically used it never before.
By Fre$hBreath Tue Nov 13, 2018 8:22 pm
You might want to consider buying a new O.S. disk. Your disco could be corrupted. There are several sellers on eBay who and they are cheap.
By 211 Tue Nov 13, 2018 8:40 pm
Never tried to update mine. This is what I would try
Are you sure the floppy drive is ok ?
Can you swap it to another one from another sampler of this era ?

Are sure of your floppies ? I know for 3.20, there's a .bat script to format the disk, copy the .320 file on it, and name the volume 'ASRXOSDISK'

My Asr-x need my scsi2sd volumes named untouched after formatting, or it don't see it.
If you made yourself the os disk, perhaps you missed something and it did'nt detect it's an OS disk

Last thing to try is via scsi, naming the volume 'ASRXOSDISK', but I'm not sure OS update could be done that way (asr-10 don't for example)
By are- Wed Nov 21, 2018 5:51 pm
Actually I have tried two sets of different floppys. I got both 3.04 and 3.20 from friend of mine who is tech and he refurbishes old samplers for sale etc. so I am pretty sure he knows what he is doing. So my old floppydrive might be the issue then. I got floppydrive on ASR-10 so maybe I should try to swap?
By 211 Sat Nov 24, 2018 1:01 pm
yep, it's the better thing to try. looking at ebay listings, it seems that ASR10 and ASRX drives are compatible.
Before to do the swap, try your asr10 drive a last time to be sure it's ok.
I looked at asr-x motherboard, and didn't see any eeprom to swap if it was corrupted.
By are- Thu Dec 27, 2018 2:12 pm
I tried to use ASR 10 floppydrive but there was no difference. Floppydrive model on ASR 10 was MPF420-1 and MPF920-1 on ASR-X Pro...
By 211 Sun Jan 06, 2019 11:12 pm
Ok, This message talk about an issue which have been solved by formatting the floppy on the asr-x first. (in french)

The error message isn't really the same, it displays "bad checksum" (usually, it means the device don't count the same amount of data as it expect. The sum of the bytes is usually written, or calculated in the OS file. The program compare it at the end, or the beginning of the update process )

EDIT : I don't know how he could did it, if his asr was bricked. -> His ASR wasn't bricked, just the new floppies didn't worked
The interesting point is he said no floppy worked as long as the formatting hadn't been done by the ASR-x itself.

Now you are sure your floppy drive is ok, you must try to make new os floppies. Do you have you to an old PC (win 98,2000 or Ms-dos) ? Can you check by yourself what was written on your floppies ?