MPC Software specific discussion - bug reports, feature suggestions and general MPC Software related topics. If you have hardware-soecific questions, please post in the relevant hardware forum.
User avatar
By GedaBlaq Thu Jun 21, 2018 3:49 pm
Just got my Advance 49 Keyboard and VIP software package yesterday.

By no means am I a guru yet but I've found a curious bug (please correct me if I'm wrong/ dumb/ this has been addressed and figured out).


When using VIP as a plugin within the MPC software, no matter what synth I use, keyboard keys C-1 - G-1 & key A-4 go bananas. Key A-4 even sometimes causes the plugin to crash.

When I press these particular keys, they don't even properly register, line up and correspond to their MIDI & GUI counterparts on screen and changing octaves just shifts the issue up or down.


1. I disconnected the Advance 49 and reconnected my Keylab 61 - Same issue, so not the keyboard.

2. Opened VIP in standalone mode, tested various instruments and both boards worked flawlessly, so not VIP.

3. Opened VIP as a plugin within Logic 10.4, tested various instruments and both boards worked flawlessly; again not VIP.


There's a glitch somewhere with the MPC software & VIP.

If there's a key range or assignment setting somewhere in MPC preferences or settings, I've missed it.

Anyone else experienced this issue or figured it out? I need these keys.

Thanks everyone and forgive me if this has been addressed and put to bed but I can't find it.
By Schmidi Wed Jul 04, 2018 5:45 am
That's weird for sure. So I'm running this exact setup using a Touch, 2.2.1 and the latest VIP (3.11 I think). I've had zero issues, so there must be something in your setup causing problems.

This may sound stupid, but are you running the 49 ONLY on USB? If you also had a physical midi cable that would be a feedback loop.