MPC Software Forum: Bug reports, feature suggestions and discussion for the MPC Software application for Mac/PC. If you have hardware-specific questions, please post in the relevant MPC forum.
By c-real Thu Jan 31, 2019 8:57 pm
Hello,

At first, please apologize my english. I will try to do my best to explain you my problems :

1) Running on Windows 10 x64, with a 125% resolution display, I noticed that MPC software doesn't open properly. It opens as if the entire application was zoomed at 125%. So it is blurry, too big and the plugin windows let a big black border on the right and down sides. That way, the app is not usable for me.

2) I have a Novation Ultranova synthesizer. I love it but if I want to automate some parameters, I have to deal with NRPN messages. But Novation provides a plugin which allows me to automate all the parameters at the same time without dealing with NRPN messages. The problem is that MPC software fail to scan the plugin. All the other plugins were well scanned excepted Ultranova.

I prefer to warn you that for 1) I tried a lot of things wihout success. I'm currently in conversion with the US Akai team (since 3 weeks) but for the moment they can't help me and say that it is not a bug. Since all the apps work well (Massive, Traktor, Reaper, Live, etc.) I suspect that this kind of problem may be fixed by the developers (but I'm not a professional).

My question is simply : if you're running on Windows 10 x64 with a 125% zoom display, does the MPC software open as if you launch the MPC plugin (which normally launches)?

This picture comes from the MPC software :

Image

This one from Ableton Live (i.e. running MPC as a plugin) :

Image

From the two pictures above, you can also see that the Hybrid plugin window is too big (125% I guess...) because it runs inside MPC software/plugin. When I run the Hybrid plugin just on his own (with Live or Reaper, without opening MPC plugin), the window displays properly, as you can see in this 3rd picture which comes from Live (running Hybrid plugin).

Image

For the second question : is there someone here who owns an Ultranova and be able to use the provided plugin in MPC software?

Thank you very much for your help and have a great weekend (maybe some of you don't go to work on wednesday :smoker: )

PS : in order to launch all the other apps properly I have to check the DPI box in each app setting, which doesn not work for the MPC software, as you guess.
User avatar
By LabDog Sat Feb 02, 2019 2:31 pm
You'll find your answer here... MPC 2 Plugin UI Scaling issue

This is most definitely an issue with Akai's programming! If it weren't, we'd be seeing this in other applications... Ableton, FL, Cubase... Etc... Akai obviously doesn't desire to fix it, so it's up to us to use Windows to fix it. There, unfortunately, is no way to control the resulting 'size' of the UI's once the feature High DPI scaling is enabled.
By c-real Sat Feb 02, 2019 4:55 pm
Hello LabDog,

Thank you for message.

As I said, I tried a lot of things before posting here, but I haven't clarify that I tested all the possible dpi settings via right-click on the app file. Unfortunately, this doesn't change the scale problem. By the way, I have to change the DPI setting (right-click on the app) for all the apps (Massive, Traktor, Live, etc.) in order to be scaled properly. But with MPC software, it simply doesn't work.

Like you, if I revert to 100% zoom setting in the windows resolution, it works fine, but everything is too small, so I can't use the computer anymore.

Can you tell me if your MPC software resolution is the same as the plugin's one please? In the pictures I posted, we can clearly see that MPC software is way too big and the plugin GUI too.

Thank you in advance.