MPC Software Forum: Bug reports, feature suggestions and discussion for the MPC Software application for Mac/PC. If you have hardware-specific questions, please post in the relevant MPC forum.
By MagiLox Sat Mar 23, 2019 7:19 am
I've been really looking into getting the MPC X. I'm putting a lot of pennies away and will hopefully have it in the next coming months...until...I test drove the software.

So maybe its because I'm using the trial version, but I'm not enjoying my experience:

1) Routing doesn't save...I have an RME HDSPe Madi FX card, driver type set to ASIO inside MPC software, when I select what inputs and outputs which takes forever between the time I check the box and the time check appears (at least 4 seconds...just not used non-snappy performance), the routing doesn't save. Even if I save the project and reload it, I need to setup my outputs and inputs again....WTF? Come on man!

2) Only 32 outputs and inputs? Only 8 submix channels? My Madi card gives me 194, but no matter how many I select, I still only get 32. Come on man!

3) I don't even understand how the mixer routing works. Why do I have 32 outputs for the masters, if I can only use 8 groups. I only have 1 active channel chosen in my audio interface, so why the heck does the mixer show selectable 32? It can't be this convoluted, I have to be doing something wrong. And before anyone ask, the drivers are up to date.


So this has been my experience so far and its depressing because this doesn't sell me on the MPC hardware so much. I hope there is someone out there that can make sense of these woes!

Thanks in advance!
By MagiLox Sat Mar 23, 2019 4:36 pm
Ok, I've done some more digging and saving as a template does not fix the fact that whenever I start a new project my routing gets reset back to what I'm assuming MPC software considers the default setting. Horrible!

I also saved a project today and even had autosave enabled...When I reloaded the project, all my midi data was gone. Horrible!

Basically, the software seems useless at this point...I guess, I'll never use the MPC X outside of standalone mode. What a gag!
By MagiLox Sat Mar 23, 2019 4:53 pm
MagiLox wrote:Ok, I've done some more digging and saving as a template does not fix the fact that whenever I start a new project my routing gets reset back to what I'm assuming MPC software considers the default setting. Horrible!

I also saved a project today and even had autosave enabled...When I reloaded the project, all my midi data was gone. Horrible!

Basically, the software seems useless at this point...I guess, I'll never use the MPC X outside of standalone mode. What a gag!



And my sample slices?!?!?...GONE! So I need to reslice the whole damn break again? WTF!??!?!?

Is this happening because I'm using the trial version, let that be the reason, please let that be the reason? I can't imagine this is an acceptable workflow for anyone if its not a trial version limitation!