MPC Software & MPC Beats Forum: Bug reports, feature suggestions and discussion for the MPC Software and the free 'MPC Beats' application for Mac/PC. If you have hardware-specific questions, please post in the relevant MPC sub-forum.
By themixtape Tue Aug 11, 2020 6:25 am
Downloaded MPC Beats recently and dug it so much I had to buy a used MPC Studio black (v2). Lots of fun.

Re: the plugin... I've experienced strange behavior when trying to get the MIDI recorded directly into a DAW (in my case, Reaper), instead of using the built-in sequencer inside MPC Beats.

Firstly, plugins and keygroup instruments when traveling on a MIDI keyboard downward from middle C... once you reach Eb2, it drops a few octaves and totally plays a different pitch. This is only when the MIDI keyboard is transmitting Midi Channel 1. When transmitting Channel 2, this is not a problem. I should note that this is when I have only one track in Reaper, with MPC Beats on it, as a plugin.

The other way I work is like this: All 8 MIDI tracks of MPC Beats are routed to different MIDI channels:

Track 1 - Midi Channel 10 (for drums)
Track 2 - Channel 2
Track 3 - Channel 3, and so on.

Weird behavior with this method: I can only get a drumkit working properly via Track 1. If I put another drumkit on a different Track, the MIDI notes are all screwed up, and it makes no sense. The keyboard view in MPC Beats shows that I'm hitting the right notes, but the pads being struck are strange. For instance, C1 (the MIDI note) plays pad A2 (when it normally plays A1), and then C#1 (the MIDI note) plays pad A1 (when it should normally play A2). The MIDI Note D1 plays pad A6. Eb1 doesn't play any pad. E1 plays pad A5, etc. Really weird.

Workaround-- create a few pad banks on Track 1, expanding on whatever preset kit I dropped in (and this was a sad revelation: apparently you can't assign any pad group / kit to Bank B, C, D, E, F, G or H? They only get assigned to Pad Bank A, even if there's only 16 samples in that kit (as most are only 16 samples)?

Just can't understand why the MIDI notes get all messed up on different tracks... and really can't understand the whole note-dropping out of range thing... depending on the Bank you're on, that Eb note gets higher and higher (by 16 semitones, which obviously relates to the pad layout in some way, but I can't understand how).

Thoughts? Has anyone run into anything like this?

Standalone, MPC Beats works perfectly, especially with the MPC Studio. But as a plugin, especially when creating 8 MIDI tracks (assigned correctly), so I can just record directly into Reaper... no luck, and all those weird problems start presenting themselves.

Thanks for any help!


EDIT: the weird MIDI notes when trying to add a second kit (with the 8 different MIDI channels routed)... I deleted that Kit from the available Programs. And then brought in a different one. And voila, THAT problem solved. Weird. Weird. Weird.
By Odum Sat Feb 20, 2021 8:04 pm
I have the same problem. Using MPK Mini MK2 below the E2 it drops low. Tried to change MIDI channels, it didn't help. Even worse, low notes was kept and high notes disappeared :) On standalone I also have problems with mapping. When I use factory preset and change the program it goes crazy. So I had to map it manually, which is very weird. I sent a ticket to support but no answer so I guess it's my last AKAI product I bought. I know it's iconic and powerful software but I'm not sure that these glitches are not present in MPC 2