Support and discussion about Akai's next generation of standalone MPCs running the MPC Software 2.0
User avatar
By zangetsu01 Thu Aug 09, 2018 10:10 pm
Hi MPC fam,

I've always been using my MPC X with my surface pro 3 or my vaio tap 21 computers in controller mode. Both models are equiped with an i5 processor. I've always known that both systems where not powerfull enough to do what I really wanted so sometimes I had to compromise before hitting the limit (the well know latency issues).

A few months ago I fired up my weaker/older laptop (Vaio VGN series with a intel centrino 2 CPU). I installed all my vst's/vsti's on it together with the MPC software and experienced a lot of audio drop outs when I say audio drop outs I mean the following:

I got 20 tracks (audio, midi, drums, plugins etc) aranged and during playback I would get random audio drop outs. I just hit play and the audio of track 1 or 15 or any other randomly gets cut out. It doesn't discriminate between audio tracks, midi, plugins or key group tracks. It just gets cut out for a few seconds and comes back and I tought that it was because of the weaker system.

I've always wanted to upgrade to an i7 system for extra power and these last 2 day I got the chance to test my cousins Asus N552V (i7/ 16GB ram/ SSD etc.)


After installing everything loads up fine, this thing is a power house. It can take all my big projects with ease. It also seems as if there is enough CPU power left to bring in some of my mastering plugs.

There is only one problem:

I'm getting the same random audio dropouts as I did with the old Vaio laptop.


I've tried the following:

1) disabling wifi (airplane mode);

2) disconnecting all other usb devices;

3) checked and disabled USB selective power settings in the power plan section;

4) Set the multi process threads of the MPC sofware to 2;

5) Tried different audio buffer sizes.

The reason I'm trying to get to the bottom of this is because I want to pick up a i7 system very soon.
My i5 systems don't have this issue but they are not powerfull enough for my needs.

Has anyone else experienced the same behaviour or any tips perhaps?
Last edited by zangetsu01 on Fri Aug 10, 2018 9:09 am, edited 1 time in total.
User avatar
By zangetsu01 Fri Aug 10, 2018 9:08 am
Problem Solved:

Found out that it was because of a few plugins. Some plugins will cut off your audio when you don't enter your serial/license, and that's exactly what happened.

Got everything running smooth now, I will upgrade to an i7 system very soon.