MPC X & MPC Live Forum: Support and discussion for the MPC X & MPC Live, Akai's current generation of standalone MPCs.
By Caustic Yoda Sun Feb 24, 2019 6:25 pm
The x/y/fx have been super laggy for me in anything other than standalone mode, in controller mode the screen becomes unresponsive and frame rate drops to half or less, been happening since 2.0 but gotten worse if anything
By D3V1L15H Sun Feb 24, 2019 6:58 pm
i looked on the forums and couldnt find how to do a factory reset. Not "reset" from the settings > info menu but a hard reset where it reverts to factory firmware so i can install 2.4 fresh. How to do this? Rather the last thing I try before calling Akai and finding out I have to ship my unit back for repair
User avatar
By 185668232 Tue Feb 26, 2019 6:26 am
In SONG MODE (2.4):

*Older song files made from 2.0-2.3, will skip sequences or glitch into freezing/silence.
*Audio tracks jump from one sequence into another sequence.
*Export of these files sounds the same as the error. :hmmm:

I have attempted some work around's in CONTROLLER MODE and STANDALONE MODE, but to no avail. :vomit:

Example: https://www.facebook.com/one8five6six8t ... SEARCH_BOX

My live performances with these bugs are making me look bugged out. :cry:

https://www.185668232.org/video
User avatar
By Oblizz Tue Feb 26, 2019 3:38 pm
The main issue I'm having (and have since the 2.3 update) is general screen lag on my Live.
Everything seems to function perfectly; Sequencing, Sampling, Editing.
It's just that the screen will skip and freeze for very brief moments while playing, not enough to say the device is broken but enough to make it so looking at the screen while playing a sequence or something is counter intuitive and annoying.

Would re-installing the 2.2 firmware (the last version to not lag the screen) then redoing all the current updates be a possible solution?
By stylesforfree Wed Feb 27, 2019 12:32 am
Oblizz wrote:The main issue I'm having (and have since the 2.3 update) is general screen lag on my Live.
Everything seems to function perfectly; Sequencing, Sampling, Editing.
It's just that the screen will skip and freeze for very brief moments while playing, not enough to say the device is broken but enough to make it so looking at the screen while playing a sequence or something is counter intuitive and annoying.

Would re-installing the 2.2 firmware (the last version to not lag the screen) then redoing all the current updates be a possible solution?


I had the same problem with my mpc x after I deleted all the factory content, I then restored the factory content which seemed to revert my mpc x back to its original factory state.
By cubilas Wed Feb 27, 2019 4:31 am
Okay, here are two fairly serious bugs in 2.4, and a feature request.

1: Renaming sequences while switching sequences adds “Next: “ to the sequence name.

Steps: Begin playback. In Main window, choose a different sequence. Before sequence switches, select ‘Set sequence name.’ The sequence name will also have “Next: “ added to it.

2. Erasing a sequence name will set its sequence number to “0”

Steps: Select any sequence. Select ‘Set sequence name.’ Remove the sequence name. The sequence will be renamed and the sequence number will become “0”


Feature request: fix range of AIR FX parameters.

In regards to the new AIR effects:

Some of the parameters are difficult to manipulate smoothly using Q-LINK knobs. This affects most controls that are not number- or percent-based.

If the parameters listed below were set up in the same way the Talkbox (vowel) control handles, these parameters would be much easier to adjust.

Here is a list of the AIR effect parameters that are tough to easily manipulate with the Q-LINK knobs:

Delay (time)
Diff Delay (time)
Distortion (mode)
Filter Gate (pattern & rate)
Filter (type)
Freq Shift (mode)
Fuzz-Wah (filter mode)
Multi Chorus (voices)
Phaser (model)
Pitch Shifter (mode)
Pumper (speed)
Reverb (reflection type)
Talkbox (LFO wave)


The Q-LINK knob response is very limited in range; the smallest touch of the knob will scroll through all selections.

Currently, it feels as if the selections are given a single number value.

Let’s say the knob has a range of 0 to 100. Each option has a single number value. When the knob moves from a value of 1 to 2, it changes. These values should be spread out evenly, just as they are with the Talkbox (vowel) selection.

Example:
Look at the difference between selecting values for the Talkbox (vowel) and AIR Phaser (model)

Talkbox (vowel) is a smooth selection, Phaser (model) is a very stiff selection.
User avatar
By zangetsu01 Thu Feb 28, 2019 10:32 am
Automation record bug:

When trying to record program master semi tune automation absolutely nothing is being recorded.
User avatar
By Oblizz Thu Feb 28, 2019 3:41 pm
stylesforfree wrote:
Oblizz wrote:The main issue I'm having (and have since the 2.3 update) is general screen lag on my Live.
Everything seems to function perfectly; Sequencing, Sampling, Editing.
It's just that the screen will skip and freeze for very brief moments while playing, not enough to say the device is broken but enough to make it so looking at the screen while playing a sequence or something is counter intuitive and annoying.

Would re-installing the 2.2 firmware (the last version to not lag the screen) then redoing all the current updates be a possible solution?


I had the same problem with my mpc x after I deleted all the factory content, I then restored the factory content which seemed to revert my mpc x back to its original factory state.


:worthy:

I think you might have solved my problem, I did in fact delete all of the factory content.

I'll get to it later and see.

Thank you!
By inkwellblack Sat Mar 02, 2019 10:37 pm
Hey there, here is my current issue after the 2.4 update:

When starting up my MPCX and selecting "Controller Mode" the red "Searching for Computer" screen starts up, as usual. On my MacBookPro, the internal SSD on the MPCX shows up on the desktop, and this is when I launch the MPC software. The software itself opens, and has been fully updated, as well as the firmware in the MPCX itself... However the red "Searching" dialogue persists, and the software sits there without Controller Mode actually syncing up.
I have tried to re-install the 2.3 firmware, as well as the "Preferences>Reset" trick... but so far 2.4 has made it so that Controller Mode does not work. The MPCX can run in Standalone, and I can browse the onboard SSD from my laptop, but that's it.

Are there any other (deeper) resets that I should try, or is there another way to force Controller Mode to work?
Thanks for any advice.
By Caustic Yoda Sat Mar 09, 2019 11:35 pm
MPC software takes 2min of black screen before it starts up? anyone else getting this, used to be quicker, not using any plug ins or 3rd party stuff , once up and running is fine, been like this since 2.3
By Cnote734 Wed Mar 20, 2019 9:21 pm
Flattening pad with effects causese Mpc x to crash,and it happens all the time,anyone had this problem.... had the Same problem with 2.3 update and still the same problem with 2.4.....