MPC X & MPC Live Forum: Support and discussion for the MPC X & MPC Live, Akai's current generation of standalone MPCs.
By Logprimo Sun Apr 14, 2019 10:11 pm
Hi.

I have an SD in the Live that i can't access in either browser or save mode. It was correctly formatted & in the browser/Save menu appears under 'Internal' with the name i gave it (MPC Samples)

I simply cannot select it, or in fact change it from 'Internal' to anything else shown.

I'm able to switch from 'Places / Content / Expansions, and select any of the options. In any other screen or menu i'm able to select whatever i choose, So there's not a problem with touch screen.

I had access to the SD card previously, but not since updating to OS 2.5

Any help would be appreciated.

Cheers!
By 40Beatz Mon Apr 15, 2019 2:14 pm
Try Reformatting the Card on the Computer 1st. Then Re-insert it in the MPC. If still not recognizing it, Card May be Faulty?
By Logprimo Mon Apr 15, 2019 6:00 pm
The Mpc recognises the card but pressing on the tab doesn't do anything. It’s like that part of thee touchscreen is dead, but it isn’t. Using that section of touchscreen in other pages is fine. I’ve reformatted, used different SD cards but it still won’t work. Someone on Gearslutz has the same issue.
User avatar
By ringmaker Mon Apr 15, 2019 9:54 pm
tap it repeatedly and it works eventually.
same issue here since 2.4 with an sd card and external hd. formatting doesn't change anything.
really annoying.
By SPL10 Thu Apr 18, 2019 1:55 pm
I’ve had this issue for a couple of updates

If you revert to an earlier version you should find that it will work as before

I spent about 2 hours on the phone with Akai support and they couldn’t work out why this had happened ... from a few Facebook posts it would seem that the other people who have had this problem deleted the factory content (like I had) so maybe that’s the issue !

A workaround is to bookmark the drive so when you press 1 (for example ) it will bring you to the SD card without having to press the drive icon repeatedly like a lunatic
By Logprimo Fri Apr 19, 2019 6:51 am
Thanks for the update.

I also deleted the Factory Content.

How do you Bookmark the drive?

Cheers!
By SPL10 Fri Apr 19, 2019 11:35 am
Select the drive as normal in the browser , press shift and whichever of the folder locations you want to assign the shortcut to