MPC X & MPC Live Forum: Support and discussion for the MPC X & MPC Live, Akai's current generation of standalone MPCs.
By Scott Righteous Fri May 17, 2019 2:50 am
I updated the MPC software today, and found out that I can't get into Controller mode properly.

I'm on OS X 10.9.5, and previously the MPC software worked fine, but now the Live gets stuck on "looking for a computer", however the pads and buttons seem to control the software, so it half works. I just can't browse menus on the touchscreen.

Then I found a thread where Akai indicate that the MPC Software 2.0 is only compatible with OS X 10.10.5
https://getsatisfaction.com/akai_profes ... 2-4-update

This sucks because I have other software that is not compatible with 10.10, so I don't want to update (I hate constant OS updates, it's a total menace to getting things done.)

Is there anywhere we can download the older version of the MPC software?
Will that work if the MPC Live firmware is more up to date than the software ?
By Scott Righteous Fri May 17, 2019 3:11 am
The thing that really burns me about Akai, is that on their MPC Software page, there is no mention of OS X compatibility limits. Also, there is no mention of this in any of the update notes, or installer notes that they provide.

Also - when you click "check for updates" from within a program, it should tell you at that point if the update is compatible with your system. Usually it's safe to update a program on a mac from within the program itself. That's how I got my MPC Software update. WTF Akai?

Also - the actual installer program itself, is supposed to check your OS version and not proceed if the software won't work, but that isn't what happened.. again WTF Akai ? Do they even know installers are supposed to work?
User avatar
By MPC-Tutor Fri May 17, 2019 6:08 am
Very odd that the installer even ran in an unsupported system. Perhaps contact Akai for legacy installers, they used to be in your account but I can only see the latest now.

Seriously though, Mavericks no longer gets security updates, you really should look at upgrading.
User avatar
By Lampdog Fri May 17, 2019 4:17 pm
Virtual Box VM's.

Create a MAC VM with old and new OS's then run whatever SW works on whatever OS.
User avatar
By Bezo Mon May 20, 2019 1:18 pm
Contact support. I can't imagine they wouldn't send you an earlier version.

Or check your account. In mine, the version available when I purchased is available (2.1 I think).
By r4nd0m Mon May 20, 2019 8:24 pm
dez perado wrote:
r4nd0m wrote:I agree with what was said about Mavericks but you can find the legacy installers here https://www.akaipro.com/mpc-live#downloads.tab - if it redirects to the normal page just click on downloads

this page is for the firmware of hardware not for the MPC software updater


stupid me - didnt check that - well I still got 2.3/2.4 installers if that helps

2.2 can be downloaded here: https://www.plugivery.com/about/pr71-AK ... m-ONLY-99/

links still work - sometimes well worth it to seach gearslutz or so for links or general announce pages like dontkrack.com to find older installer links that still work ...

Edit 2.3 is here https://cdn.inmusicbrands.com/akai/23/MPC-v2.3Mac.zip