MPC X & MPC Live Forum: Support and discussion for the MPC X & MPC Live, Akai's current generation of standalone MPCs.
User avatar
By optik415 Tue Aug 27, 2019 1:19 am
Not sure what's going on but using the Live as an interface with FL Studio is giving me problems and it's basically unusable. Everything is fine when I'm using it with the MPC software and Reaper but for some reason it won't work with FL. When I open FL I have to switch to primary sound driver and then ASIO MPC Live driver for it to work and once I load a plug-in or clone a FL channel all audio stops and nothing will play, basically disabling the Live as a sound card. To get it working again I have to switch to primary sound driver and back to MPC Live asio driver which then ends up to be a vicious cycle making it unusable.

I'm using Windows 7 and I just reformatted my computer with a clean install. This is the only issue setting me back. Any help or suggestions would be much appreciated, Thanks
User avatar
By optik415 Tue Aug 27, 2019 3:28 am
mr_debauch wrote:can you install asio for all and try and use that with it instead of the ones supplied with the live? I have not tried myself.


I can try later for sure! Currently away from my studio but if you can possibly see if it works that'll be great
User avatar
By quietizkept Thu Aug 29, 2019 12:33 am
I find FLASIO **** on ALL other drivers for my last 5 audio interfaces (I know I have a problem). I mean CPU usage wise - meaning I can run lower latency stably. It does add a bit of latency, but I can turn it down to better than the corresponding real ASIO drivers.
It should have been an option in your installer. I almost can't live without it.
User avatar
By optik415 Fri Aug 30, 2019 1:35 am
quietizkept wrote:I find FLASIO **** on ALL other drivers for my last 5 audio interfaces (I know I have a problem). I mean CPU usage wise - meaning I can run lower latency stably. It does add a bit of latency, but I can turn it down to better than the corresponding real ASIO drivers.
It should have been an option in your installer. I almost can't live without it.


So I'm actually running the ASIO4ALL driver and selecting the MPC Live and it's been working fine. Figured I would have to use the actual MPC Live driver but guess it doesn't work with FL Studio. Thanks for the help