MPC X & MPC Live Forum: Support and discussion for the MPC X & MPC Live, Akai's current generation of standalone MPCs.
By Jez808 Fri Sep 06, 2019 7:08 am
hello all
I have not been able to find any info online. perhaps someone here can help..

I just bought the Live today and after about 2 hours it crashed with - "your mpc has recovered from a problem" or something like that and reboots to template screen.

I've gone from thinking what an amazing machine to what a piece of junk and don't want to even waste time using it any more

first track was just kick/snare/hat with a few minor effects on each, then i selected track 2, pressed the plug in option and bang freeze, dead

so my question is - is there some kind of diagnostic utility that can check for drive errors and such?

Surely there is something corrupt, I wouldn't take this machine to my grandmas let alone attempt a live gig

I did install a 120gb crucial ssd. I've read they may not play as well with mpc as samsung is this correct?
I also updated to latest firmware

please stop me from flushing this piece of junk down the toilet.

thank you!
User avatar
By Monotremata Fri Sep 06, 2019 7:41 am
Thats weird theres been a couple reports of this same thing with brand new units in like the last week over at the Akai forums too (unless youre one of them?). I wonder if a bad batch went out or something?? The last one I remember the Akai folks told the guy thats the CPU overloading, and to make sure the internal storage wasn't full and start saving on an external heh.
By Jez808 Fri Sep 06, 2019 11:49 am
ok I've calmed down a bit now, rant over

maybe it was just bad luck as it has not crashed again even under much heavier load

my old 2000xl would crash a bit too but I learnt what not to do, spin jog wheel too fast on effects etc.

just a really bad first impression of the unit. I'll certainly be saving frequently

I'd love to know of any diagnostic tools or secret service settings if anyone knows

Thanks!
By CharlesRandolph Sat Sep 07, 2019 12:41 pm
Jez808 wrote:hello all
I have not been able to find any info online. perhaps someone here can help..I just bought the Live today and after about 2 hours it crashed with - "your mpc has recovered from a problem" or something like that and reboots to template screen. I've gone from thinking what an amazing machine to what a piece of junk and don't want to even waste time using it any morefirst track was just kick/snare/hat with a few minor effects on each, then i selected track 2, pressed the plug in option and bang freeze, dead

so my question is - is there some kind of diagnostic utility that can check for drive errors and such?
Surely there is something corrupt, I wouldn't take this machine to my grandmas let alone attempt a live gig
I did install a 120gb crucial ssd. I've read they may not play as well with mpc as samsung is this correct?
I also updated to latest firmware please stop me from flushing this piece of junk down the toilet.

thank you!


Use Sandisk or Samsung, I would avoid Crucial if you can.
By Stumm42 Mon Sep 09, 2019 6:26 pm
My mpc x crashes all the time on new firmware. I'm hoping when new firmware comes out will stop it crashing.it don't like to much automation even with just a few sounds. 2nd one I have had so deffo a software bug
By godlike Mon Sep 09, 2019 8:47 pm
My MPC X crashed so much using the new software that it is unusable at this point. I contacted support and have not received any feedback.

So...I am back on my Push 2 and Maschine Studio. I hope the next software update is better. :popcorn:
By 40Beatz Mon Sep 09, 2019 9:12 pm
Is your internal Memory, Molested in any way shape or form? Like have you deleted any Expansions? Hopefully you haven't done that. Sometimes that'll cause a problem
By Stumm42 Tue Sep 10, 2019 10:17 am
godlike wrote:My MPC X crashed so much using the new software that it is unusable at this point. I contacted support and have not received any feedback.

So...I am back on my Push 2 and Maschine Studio. I hope the next software update is better. :popcorn:

Mine crashes about every 10 mins. 2nd one I have had and still the same.100% it's the new firmware doing it. Akai can't even be bothered to reply to my emails
By Stumm42 Tue Sep 10, 2019 10:21 am
40Beatz wrote:Is your internal Memory, Molested in any way shape or form? Like have you deleted any Expansions? Hopefully you haven't done that. Sometimes that'll cause a problem

No.its 100% the new firmware.2nd one I have had. Got another one yesterday.ran it on old firmware for a hour.no probs.put new firmware on.within 10 mins internal error. Tryed for last 3 weeks to email akai.no answer
User avatar
By Ill-Green Tue Sep 10, 2019 2:34 pm
Akai hardly checks their email. However, on the software, the smiley face is how you contact Akai for bugs and things.
By 40Beatz Tue Sep 10, 2019 6:32 pm
Stumm42 wrote:
40Beatz wrote:Is your internal Memory, Molested in any way shape or form? Like have you deleted any Expansions? Hopefully you haven't done that. Sometimes that'll cause a problem

No.its 100% the new firmware.2nd one I have had. Got another one yesterday.ran it on old firmware for a hour.no probs.put new firmware on.within 10 mins internal error. Tryed for last 3 weeks to email akai.no answer


Are you Re-Downloading the 2.6 Firmware or are you tryin to re-install the Same File you downloaded previously?
By Stumm42 Tue Sep 10, 2019 7:16 pm
Are you Re-Downloading the 2.6 Firmware or are you tryin to re-install the Same File you downloaded previously?

[/quote]
downloading the firmware twice now.tryed on 2 different mpc x. Cpu never go's above 20%. Been doing automation but nothing more than with old firmware