Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
By Dbolfreak Sat Feb 27, 2021 5:29 am

I run into very peculiar issue with MPC Touch when after upgrading to OS Mojave from OS Sierra it briefly worked and it crushed. I managed to uninstall and reinstall the drivers as instructed on Akai pro knowledge base page and it worked twice than it crushed the third time and it's not coming back. I repeated the process uninstalling and reinstalling the extensions, uninstalled the Display link USB Graphic Software 5.0 tried 5.1 nothing works. I repeated all the combinations like 40 times and every time wench trying to configure display it's stuck on searching for device and the MPC Touch is lit like a Christmas tree. It seems to be a conflicting information regarding the display driver installation; there is a page on Akai pro which instructs to install the display driver for MPC Touch directly from the Installer, and than there is another page where they specifically instruct not to do so but to install the Display Link USB Graphic Software for Mojave OS 14.14. Is there anyone that can share some light on this matter. I'm very computer, software savvy and never had any similar issue, what am I doing wrong. Appreciate any help and sorry for the extended post.