Bug reports & end-user support for Akai's MPC Software 'controllers' including the new MPC Studio 2, the MPC Touch, MPC Renaissance & original MPC Studio and MPC StudioB lack.
By Butterbird224 Tue Jan 25, 2022 8:05 pm
Hey all!

I just got a broken MPC Renaissance in December in an attempt to repair it myself. I've just been having the same issue since then and I'm running out of ideas.

Whenever I plug it in, the screen starts flickering but it doesn't boot up at all. I opened it up to see if it was a hardware issue and cleaned up/re-soldered the little amount of corrosion that may have been messing it up. But it still wouldn't boot up.

I also tried to give it a Firmware update but my mac didn't recognize it. I was thinking of maybe putting it in DFU mode or doing a hard reset so my laptop could recognize it first as an external drive and then I could install the Firmware. If any of y'all know how to set up DFU mode or do a hard reset for MPC Ren that would be really helpful, as well as any other advice.
(Keeping in mind that I CANNOT access anything on the screen)

I've looked on other forums and seen people have similar issues with the ren but no one has any information on how to actually fix this issue.
Any advice would help,

By Ryumacleod Wed May 18, 2022 8:38 pm
I’m working on my uncle MPC Ren as well & have the same problem. Have you checked the power board with a multi meter? I found a short in this one. If you check for continuity, put one test lead on the positive pin of the power jack & the other on the negative. If you hear the beep, you have a short. The first diode near the jack (D9) was fried on this one. I was able to remove it easily, but can’t find out the value of the diode to replace it & fix the circuit. Here’s the info that was etched in the top of it: PJ2256 DZV. If anyone can find out what it is or where to buy some, your help will be greatly appreciated. Thanks.
By Budd Sat Jun 18, 2022 6:10 am
Mine did the same thing, changing to fat pads, I even left out the light cover for the shift or something, the lil yellow clips, and a foot, but it blinked twice after forgetting to put the onboard light covers back, well one.

I just threw it back together, and now it works, try to get it to stop while you have it open, it is dangerous, i wouldnt recommend anyone be plugged in with a live board but, I wasnt loosing, i didnt ground, i just got it to stop, then slapped it together twice and now the pads are way too big and I thought the originals were bad, sux. Ill try playing it live when i lay down a drum on the fly, but im out of wub, 809, bank, rex, and wav loops. It stops blinking though if you watch it plugged in open, aint no way you can screw 100 screws in without knowing it is lit, or not glitching. Good luck with it, make sure the scuzzi is in right =]