Reviews and questions about the entry-level MPC500
User avatar
By DjDiskmachine Sun Mar 04, 2018 9:38 pm
Hello MPC-lovers!
I've realized there are quite many posts on the subject about MPC 500 being noisy either on inputs when sampling or outputs or both of the above. I had this problem myself, and I did some detective work on determining the cause of this. As a few users reported their unit wasn't noisy and the previous owner of my unit hadn't said anything about it, I considered the possibility that my unit had gotten worse with time. I managed to solve it with an audio probe, new caps and my trusty soldering iron. I write this guide hoping that this post will be helpful to some of you that are experiencing the same problems. Also, if you find my description confusing, please drop a line and I'll explain a bit more and/or update the guide. =)

TLDR; so what's wrong with it?
I came to the conclusion that AKAI used a few components of lower quality to save manufacturing costs when constructing this unit. In short terms, this causes the power supply lines in the machine to have a dirty DC supply which in turn appears in the parts that handle audio amplification etc.

Causes
-Reason 1:
The behaviour is caused by using a (cheap) switched power supply that itself has a noisy voltage output.
-Is this a problem with my unit?
Might be! Get yourself a pack of fresh batteries (not the cheapest brand u can find for this excercise). Put em in, start the machine without a PSU.
Inputs / outputs still noisy? Read on further down. Noise gone - great! Get yourself a good PSU from your local music shop, doesn't need to be anything fancy but at least you can go back and swap it out easily if it doesn't help. Try another brand before continuing.
-Why does this happen?
This means your PSU is struggling to keep a constant voltage output due to the current draw being to high from the machine. Not uncommon for cheap PSUs that have a current rating lower than the value stated on the sticker. This is actually a bit hazardous for your work flow and might cause stuff like hanging while loading, reboots and corrupted saves.

-Reason 2:
Bad capacitors. A more tedious solution, but if performed correctly will produce great results. See guide below.
Note! Please let someone with quite a habit of soldering stuff do this, this is a bit more fiddly than soldering jacks to your audio cables.
Also, always unplug all power supply sources and ground yourself while operating the bare PCB of the machine or you might risk breaking something that is very hard to repair.

So- your unit seems to display the same symptoms as mine did. Don't worry, let's get engineery.
MPC500 service manual, a useful read for everyone interested in maintaining a unit of good health: http://www.synfo.nl/servicemanuals/Akai ... MANUAL.pdf
See this thread for my notes on diagnosing the problem: viewtopic.php?f=26&t=183490&p=1731157#p1731157
References below containing the form "C9##" are references to Electrolytic capacitors, an electrical component that is common in filtering circuits.

I suspected the capacitors that are associated with decoupling the output voltage from the power regulators to be the cause of my problem. The caps are all by the brand Lelon, after doing some measurements as well as consulting with a friend that does a lot of Amiga re-capping, I made the conclusion that the electrolytic caps were starting to go bad. This is a common phenomenon in cheap capacitors and a bit of a nuisance.
My friend made the recommendation to get a japanese brand, and I decided to go with a brand called Nichicon that was available from my goto electronics store.
Check Mouser, Elfa or similar retailer web page for your options.
The type you need to get is called Radial electrolytic capacitor, I picked this type: https://www.mouser.se/ProductDetail/Nic ... mA9VOTs%3d

The caps that need to go are C907-C912 and can be seen on the last page of the MPC service manual.
Both the power jack and the battery line will be led through three Integrated Circuits; IC901-903. These are LM2674M-ADJ, adjustable step-down switching voltage regulators that produce the 1.7, 3.3 and 5V power lines that all need filtering. These can be seen in the top right corner, last page of the MPC service manual.

C907-C909 are of the value 100uF (100 microfarads,16V) and C910-C912 are of the value 220uF/16V (220 microfarads/16V). The Volt tolerance doesn't matter so much, the MPC operates on 5V logic level so just pick any value as long as it's not a lot more than 16V as the caps you recieve on the mail will be huge and might nog fit in there. :D
It's not necessary to replace all of these blue cylindrical caps, just check the PCB next to the components, there will be a C9##-marking next to the cap to show which one it is.
These can all be seen in this picture here: https://www.instagram.com/p/BY_oUn0nSuF ... iskmachine
And after re-capping: https://www.instagram.com/p/BZCS0jpH9cw ... iskmachine

There's a dissassembly guide on how to screw the MPC here: viewtopic.php?f=26&t=184022
..aand here is a great tutorial on capacitors and how to replace them:



GLHF!
By lamalta129 Mon Mar 12, 2018 11:14 am
I just wanted to throw my weight behind this post real quick and say that this absolutely works.

I was able to replace the caps on one of my two noisy 500s last night and the whining noise is down to where you would only ever notice anything with headphones on full blast preamped through a mixer and NO samples playing with output set to -6.

I’ll provide a few tips and details when my job and family allow time and I look forward to doing my other 500 too.

I would not have the knowledge to know where to begin without this place so thank you so much for imparting this info on us.
By lamalta129 Tue Mar 13, 2018 6:11 pm
Buttoned up my second 500 after doing the caps last night and can confirm that the noise went down on this one as well. Excellent.

Here are some observations and notes. Will probably have more later:

I have no qualifications to have an opinion on the use of “premium” audio grade caps. I used the Nichicon Fine Gold also used by the OP because he said he got great results and I just wanted to eliminate the possibility that my choice of caps would have something to do with a bad result. As mentioned watch your sizes. Places seemed to be out of the 16v caps so I went with the 25v ones instead but had to lay the caps down on side and bend the leads down to the through holds so the board would fit back in its case.

Both 500s I replaced caps for had a similar noise but in different pitch. The noise level also went down when master volume was around a sweet spot of 3 o clock for both. Now with the new caps if you crank the headphone output of a preamped 500 (that is the master outs preamped through a mixer board with a more powerful headphone out) you can still hear this noise but is just much quieter to where I’m comfortable ignoring it is there. You wouldn’t hear it without headphones, without it cranked or especially with anything playing through the MPC. You can still make out that the noise floor goes down at 3 o clock with it cranked so that is where I leave it.
By lamalta129 Tue Mar 20, 2018 10:07 pm
So of the two that I recapped, one of them is still enough noisier than the other that I’d be willing to experiment replacing some more non-surface mount caps if there were any other through hole caps on the board that might aid in this regard besides c907-12?

Something maybe of note is the noisier board has a noticeably brighter LCD backlight.

Potentially of interest is that I have two power supplies I experiemented with. One is switching and turning the backlights on or off on either of my 500s does not seem to have an effect on the noise either way. Noise is acceptable with the more dim backlight LCD 500 but is still a little irritating with the brighter LCD unit (obviously we are the sort to be anal retentive enough about these matters that we are willing to take apart our machines) possibly due to the noise on that unit being of a lower pitch. The other PSU appears non switching variable voltage with a switch to reverse polarity and is quieter than the switching PSU with the backlight off, but appears to me possibly noisier when the light is on both units.

Ideally I’d like to use a PSU and with the backlights on which is why I would be curious to why my one 500 is still a little noisier than the other. The pitch of said noise on the noisier board is a lower whine than the other board with the more dim backlight.

I do not have pictures (will try if I can) but the boards on my two 500s are actually slightly different where the smaller uf caps go. The through holes for one cap is rotated 90 degrees to where the other board has them laid.

If anybody is wondering why I have two 500s and why this interests me: I want to experiment “DJing” with two 500s.
Last edited by lamalta129 on Tue Mar 20, 2018 10:17 pm, edited 1 time in total.
By lamalta129 Tue Mar 20, 2018 10:15 pm
Sorry if it seems like I’m bugging you all to do the mental leg work for me. This has been a good learning experience but a little frustrating that while I seem competent enough thus far to remove and solder the components I otherwise do not have the knowledge of electric engineering that you guys do. In another life maybe.
By lamalta129 Wed Mar 21, 2018 3:16 am
OK. After auditioning both again I realize I’m probably getting a little obsessive.

With the non-switching PSU and the backlights off, both are very sufficiently quiet in terms of noise.

I guess my problem is that where I would use my 500s I would need to use the backlights because it will be dark.

With the backlights on you can hear both emit noise, though admittedly much quieter in comparison to the old caps.

So I guess my last concern is, since we’ve come this far, do we know of a way to filter out the noise the back light emits into the machine?

I know in one of the posts you mentioned there was a cap C175 that decouples the backlight from the power rail.
User avatar
By DjDiskmachine Wed Apr 04, 2018 1:53 pm
Good news buddy!
Happy my haphazard novel was to some use to somebody :D

Good that you brought the topic of backlight noise up, I personally didn't care that much about it since I'm an overly-lofi type of person.. Might as well fix everything when you're at it rite? :D

Correct, I did mention that the BL was decoupled by C175.. When re-inspecting this part of the schematic (last page in Service Manual, at the bottom of the page between sections B and C) one can see a variable resistance. This is the contrast trim potentiometer. Try fiddling with it and see if it affects the noise floor at all. My guess is that it does, and in that case try replacing that cap.
If not, I'd say the culprit is C914 at D2 ... Kind of unlikely tho as this handles super-high oscillations and is most likely used as a debounce filter.

Lemme know if u get anywhere with this and I'll update the guide for future explorers. :D
By Emilie Wed Jun 06, 2018 5:48 pm
Thank you DjDiskmachine for taking your time to post this. The mpc-500 is a fine machine, but you are right that alot of the components are cheap and low quality.
User avatar
By inflict3 Sat Jun 09, 2018 3:28 pm
Nice work y’all! Now I know where to start if my noise become louder.....thank you.
User avatar
By JUKE 179r Mon Oct 01, 2018 10:30 am
Great info!
I noticed some noise from the outputs when it's using batteries. When I swap out and use the power plug, the noise stops. :hmmm:
I'll try this mod and see how it goes.
User avatar
By DjDiskmachine Tue Oct 02, 2018 8:45 am
JUKE 179r wrote:Great info!
I noticed some noise from the outputs when it's using batteries. When I swap out and use the power plug, the noise stops. :hmmm:
I'll try this mod and see how it goes.


Interesting! Were they fresh batteries or used ones?
Good luck, please debrief on your results =)
User avatar
By NearTao Sun Dec 02, 2018 11:16 pm
Booted up my 500 after three years in cold storage... woah does it have a really bad high pitched whine. Just saw this, and ordered some caps. Will report back in for how things go once I get it done. Sad the old pup wasn't able to play, but glad some folks here have been working to keep them in shape!
User avatar
By NearTao Mon Dec 10, 2018 12:19 am
Well the new caps fixed my 500, thanks for the post!

Only weird thing I have now is sometimes the audio crackles a bit, and I've found if I put pressure on the MAIN VOLUME pot it goes away. Not sure if I accidentally introduced a short or not, but will have to keep an eye on it.
User avatar
By DjDiskmachine Thu Dec 13, 2018 5:22 pm
NearTao wrote:Well the new caps fixed my 500, thanks for the post!

Only weird thing I have now is sometimes the audio crackles a bit, and I've found if I put pressure on the MAIN VOLUME pot it goes away. Not sure if I accidentally introduced a short or not, but will have to keep an eye on it.

Alright! Happy you got some quality out of my howto =D

Sounds like you have a loose pin somewhere, could be a cold solder joint. Was the crackle there before you started re-capping?