Bug reports & end-user tech support for Akai's generation of MPC Software 'controllers' - MPC Touch, MPC Renaissance & MPC Studio.
User avatar
By tsutek Mon Dec 17, 2018 7:53 pm
I got fckd by High Sierra too so spent a weekend reinstalling Sierra and all my software. Thank the gods everyhings working again.

If you are unable to install Mojave, stick to Sierra. If You update High Sierra beyond 10.13.2 you will be SOL
By themixtape Sat Aug 22, 2020 7:46 pm
Bought one used. Could NOT get it to work. Windows 7, 64-bit.

Followed the installer instructions to the letter (restarting after EVERY step). Nothing. All it showed on the screen was an extension of my desktop wallpaper.

I did everything right. Every single thing. I spent two solid days uninstalling, reinstalling.

Every time the USB cable was connected to the computer (the final step), driver installation failed. "Akai Professional MPC Touch"... failed every time.

I disabled Digital Signature blocking, too... which was the cause of the problem... or seems to be. Still, would not install.

If anyone knows any tip/trick to get it working with Windows 7, please let me know. I googled everything and found nothing helpful.

I even tried newer versions of the DisplayLink driver... nothing worked. Nothing.

I'm happy with my MPC Studio. I just would like to try the workflow with the Touch, as I never tried it or the Live before.

Thanks!