Reviews and questions about the entry-level MPC500
By dodecaphonic Mon Oct 29, 2018 2:47 am
hey everyone hows it going,

i have a pretty much an unused mpc500
i recently wanted to expand the ram so i got the required ram
installed the ram now every time i turn on the mpc it is stuck on the 'mpc500 startup' screen and is frozen

i've done the os reinstall from the cf card it installed the OS but same problem
i take the ram out of the unit and it boots as normal to 16mb put the ram back in and it doesn't get past the mpc500 startup screen,
I have the correct ram i also have tried the official akai brand red ram for this unit aswell and have had the same problems

can anyone here help?

User avatar
By JUKE 179r Mon Oct 29, 2018 12:00 pm
Ensure the RAM stick is fully seated in the slots.
By dodecaphonic Mon Oct 29, 2018 10:30 pm
hey the ram is in there nice and firmly,
taken it out put it back in etc, still no recognition
the best result i have had so far is a message that came up after one insert :
SODIMM test 128M
pass 1 : 49%

i've had that twice and each time once it reached 50%
an error ram problem came up - and i would have to reset.

so i'm not to sure,
the RAM is new - i think its possibly not making a connection with the pins in the mpc ram enclosure

i'm not to sure what else to do thanks for the advice
any suggestions would be awesome as this kinda sucks if i can only have 16mb of memory :/


User avatar
By JUKE 179r Tue Oct 30, 2018 9:47 am
Try this...
Emilie wrote:[Page 106:

Initialize To Factory Default
Various Sample and Sequence settings can be saved to Compact Flash when the file is saved. The global settings found in the MPC500
(listed below) are saved to the internal Flash Memory and stored when the MPC500 is turned off. You can re-initialize the Factory Preset
settings using the following procedure.

1. Turn the MPC500 on while holding the [ERASE / UNDO] button.

2. Release the [ERASE / UNDO] button after the display shows [MPC500 (##MB installed)].

Now the MPC500 is reset to the Factory Preset settings.
By dodecaphonic Tue Oct 30, 2018 10:11 am
hey thanks for the reply again!

tried that and did a reset to the factory settings still not reading the inserted RAM

I think i might have to get a replacement of the ram slot in the mpc,

does anyone know if this can be done / how hard / technical this is?
I can make do with 16mb memory, but i would really like to max it out to its full potential.

By bt2001bt Sun Nov 04, 2018 8:25 pm
I am having the same issues right now. About a month ago upon bootup, my 500 went into RAM diagnostic mode also. It always makes it to Pass 4 50% and then gives me an error. I happen to have two other RAM sticks, get the same results.

The RAM slot is mounted to the bottom of the main board through surface mount technology from what I see. I doubt you can easily replace it, I don't believe I could. I have my doubts if that is the issue. I could be wrong on both counts.

My experience, and this is my second mpc500 that I have had issues with, is that the main board or some of the ic components on it become unstable over time - or there are bugs in the firmware/os that eventually manifest themselves - leading to issues. I have not tried the factory reset yet, but don't expect it to resolve my memory issue. Who knows, probably worth a shot. Like you, I might be limited to using it with 16 mb ...

I am having some issues in that mode with sounds cutting out when I build a sequence, which I believe is related to polyphony limitations and I assume the memory limitation of 16 mb. Probably need to look at what autoload is loading up ...

Don't mean to be negative Hopefully maybe someone with this issue in the past will speak up. I am going through old 500 posts, if I see something I will reference in this post.

I will also add:

In the absence of knowing what the issue is, most things cannot be ruled out ...

You cannot rule out that the ram that you purchased as not working. I cannot rule out the two additional ram sticks that I have as not working as I never tested them, just had them - bought them cheap - in case I needed them. It can certainly start to get expensive getting additional parts to test and try to eliminate causes.

In the case of my first mpc, the display does not work. I bought a $65 replacement lcd and it still does not work. Ouch. In this case, I believe I will live with the 16 mb ...
By dodecaphonic Thu Nov 15, 2018 5:02 am
hey, yeah its pretty annoying stuff

I purchased the mpc500 new and I have had the same problem since,

I have never been able to load ram onto it,

I'm not even sure if its functioning properly in the OS,
but i guess i will persevere i probably will never be able to fix it,

it was probably a dudd when i bought it, i don't know a bit perplexed i suppose :D

thanks for the input
User avatar
By JUKE 179r Thu Nov 15, 2018 8:40 am
Are you guys using the AC power cord and not battery power when you boot up the MPC500? Could be low batteries.
What about removing the CF card from the 500 while booting up? Still no changes to RAM issue?
Are you using a PC 133 144PIN CL3 SODIMM 256MB RAM stick? Some forum members noted that you'll need the 256MB RAM stick in order to get the MPC500 to acknowledge just the max 128MB . I know... it sounds weird and thanks to Nukai for that dumb sh!t.

I'm curious to know the issue behind your RAM problems.
User avatar
By JUKE 179r Thu Nov 15, 2018 11:38 am
Damn... that is weird...

Try a different AC power adapter?
fuzuku wrote: I was using a 12V 850mA adapter, and no way, it keep stuck in the main screen, like 80% of the time when I first started using it. Now it keeps stuck all the time with that adapter. I wouldn't recommend plugin it in to your MPC .

I stopped using that one, and switched to a 800mA adapter, same voltage, and no problem. Works perfectly.
User avatar
By Ill-Green Mon Dec 03, 2018 10:59 am
MPC500 has a 500mA 12v AC.

What brand and type of RAM did you get? Not all are compatible, though some have successfully used 256MB in the past.